Toon Shading in 2.71

So it seems like Blender made toon shading significantly harder in the newer versions and now I can’t follow any tutorials on toon shading properly.

So I’m basically trying to get hard lighting and black edges like this:


How can I do that with the node editor?

I realize this was made several days ago, and as such you may have found an answer yourself, but I believe I can answer your question.

To toon shade something, you don’t need the node editor, in fact i dont believe it can even work with the node editor as the thing that makes the lines(freestyle) was developed for blender internal, not cycles(anyone feel free to correct me on that if im wrong).

First, make sure your render mode is set to “Blender Render”, not “Cycles Render”.

Then go to the render tab(the one that has a camera for an icon). There should be a checkbox for “Freestyle”. Check the box and hit render, you now have lines on your model.

To get toon shading, make sure the object you want toon shaded is selected and go to the materials tab, if it doesnt already have a material then add one.

Change the “Diffuse” and “Specular” settings to Toon. make sure your lighting is good and your done.

Of course you’ll have to play with the settings for the lines and the material but this should get you to that point.