Top third of image randomly not compositing?

I made up a quick scene to test out the new snowflake generator and volume rendering. When I rendered out the animation, I ran into a problem where the top third of the image randomly wouldn’t do any compositing:

The memory usage also seemed really off:

Any ideas? If this was any sort of serious animation, I would just render it out without any compositing and then do the compositing in 2.69 official release or something. I was just wondering if this was a known problem with a known fix, or if I should report it, or whatever? Thanks in advance!

EDIT: If you want to look at the blend, I can give it. I’m using my own build of Blender, updated and compiled yesterday in the evening. It says 2.69.10, if that helps at all.

Only suggestions without access to your file or nodes would be to ask if there are scale nodes involved? Sometimes they act in a hard to predict fashion.

There aren’t any scale nodes. Here’s the setup:

Not sure… hmm, why set alpha at the input nodes?

Try attaching a viewer node to each step, perhaps you’ll find an offending node that way.

Erm… Honestly can’t remember why those nodes are there… I’ll remove them in the morning.

I already tried that, sometimes it would be fine, others it wouldn’t. It was random. Which node I used didn’t matter.

But you are trying to find the offending node. That is somewhere in the chain that an alpha chanel fails or a mix node fails.

I think that it is odd that the bottom half is ok AND remains in place. If it a frame is rendered only in part it would tend to either move up and start at the top…

For anyone who finds this on Google or whatever in the future, turning off OpenCL seems to fix the problem. Also, thanks to 3pointEdit for helpin’ out.

Hmmm, seems like it might be worth a bug report… OpenCL is worth fixing :wink: