Tracking drone footage won't reproduce FOV

Hi, I have a Yuneec Q500 drone and shot some simple footage at the beach. The tracking markers worked great very low noise. Solve error at 1.07px I ran solve camera motion and the markers track the footage but if I add an object it’s totally EFFED!

The specs say the camera is a 7.7mm sensor (1/2.3) with 6.16 width, it has a 14mm lens resulting in 115 degree FOV. When I solve the camera, I get 57.9 FOV or a 5.56mm lens. It’s causing a problem with perspective as a cube just doesn’t follow the same vanishing points. Almost looks like an isometric cube on wide angle footage - ugh.

How can I fix this?

If you know for sure manufacturer camera specs, sensor size and focal lenght, input those parameters in camera settings and don’t refine it. Verify each of your trackers for possible errors. To check field of view, after creating your camera in a 3D scene, change in Object Data Properties > Lens Unit > Field of View.
Normally drones and smartphones try to create a DSLR image and tracking softwares often fail to solve. Try using Blender default settings refining focal lenght. You can also use fSpy in a single frame to help guess a focal lenght.

Also for Blender matchmove you should aim for below 0.5 px solve error.

Thanks, I had verified all those specs numerous times. Sometimes Blender overwrites them and when I change them back all hell breaks loose. I can’t seem to get it below 1.0 pixel error but I’ve had way worse error and able to resolve on previous projects. This is melting my brain. As far as I’m concerned this is probably one of the easiest scenes I’ve tracked. It’s basically a wall and boardwalk. plenty of clean track points. Crazy.

I think I solved the problem. Error is 1.56px but looks good. In my footage I had to track a street light that was way off in the distance. I assume this track point produced the proper parallax so blender could calculate the world better.