Train tracks curve/array modifier problem

Hello hello,

So I have this problem: I am making a long and winding train line, by making one small section of the track, duplicating it with an array modifier, then using the curve modifier to make it curve to a path. After this, the camera is also tracked to the path and follows the train tracks along nicely, simple eh?

So yeah, it was working fine with my bezier curve, edited the time ipo, all good. But then I realised that I wanted the train tracks to move up and down in the Z axis along with the X and Y, something which a bezier curve can’t do, so I make a path instead and do the same procedure. However, now the track “bunches” at either end, with each wooden plank across the track (no idea what they’re called) getting closer and closer to infinity and in the middle being stupidly spaced apart. I’ve searched the forums but the only answer is to use a bezier curve, though obviously then it has to lie flat on the ground. Any ideas what I can do?




I’ve not tried so no idea if it will still work but have you tried switching on 3D (Curve and Surface settings) for the bezier curve so you can then move it in X, Y and Z space.


You, sir, are an absolute genius! Cheers mate, really appreciate it, seems so obvious now :slight_smile: :o