Transp in viewport 2.83?

how can i change this transp when selecting an object ?

i tried Shading X-ray and it odes not change it

i’m in solid mode

so how can i change this ?

z2

thanks
happy bl

Hey, @RickyBlender! I think you are saying that you want the object to appear over other objects in the scene. Is that right? If so, you want to use the In Front option in the Viewport Display section of the Object properties.

In Front on:

In Front off:

If you’re looking to do something else, please let us know!

is there a parameter for this in user preferences
i mean you’d have to do that for all objects !

i did see that one in ob prop
but still not what i’m looking for

it is more the transparency thing of selected object

in 2.79 it did not do that it was solid and not transp
there might be some parameter for that but where?

thanks
happy bl

here is example in 2.79
when i select object it is not transparent behind other ob

thanks
happy bl

Just to be sure we are talking about the same thing - in 2.79, the object selection highlight occludes behind non-selected objects, and in 2.8X, the object selection highlight is above all objects. You would like the selection highlight to be obscured behind non-selected objects like it used to be, correct?

If that is the case, let me take a look, but I’m not sure there is a setting to change that back to the old style.

yes be able to select either method if it still exist in 2.8

i tried a lot of setting in Shading menu or object
and cannot get equivalent to 2.79

mind you there is also the fact that in solid mode i cannot select verts
it is always occluded by other things
but may be there is a way

thanks
happy bl

Hmmm…I feel like I remember watching a video walkthrough of the viewport changes in the works when 2.8 was still in alpha, and the new style of selection highlighting was mentioned as an “improvement” I believe. We’re you able to select verts in solid mode in 2.79? Is that the functionality your are hoping to gain by changing the selection highlight occlusion? Have you tried the alternative depth picking setting in the Viewport section in Preferences?

https://docs.blender.org/manual/en/latest/editors/preferences/viewport.html#selection

did not see the depth picking
will do some testing

i saw several thread for verts selection
and still being a problem

so you are saying that the old 2.79 method does not exist in 2.8?

thanks
happy bl

did some test on the OpenGL Depth Picking

but did not find any difference

is there a difference and how to make it work?

thanks
happy bl

So, I can’t say for sure when the selection highlighting changed, nor whether or not one can bring it back - only that I can’t find a way to bring it back. Regarding the alternative selection picking method, the manual says that it really just depends on your hardware, so you may not see any noticable difference.

What graphics card are you using and are your driver’s up to date?

i have a very simple video card not even recognizes as GPU
nothing high end

so probably could be the video card!

for the transp thing did many test and cannot find and equivalent to 2.79
may be it is not possible!

thanks
happy bl

just found something by luck

in material proper
under viewport visibility
increase the metallic value and
it begins to look more solid like in 2.79

happy cl

Hey, @RickyBlender, I just came across this in the manual today: https://docs.blender.org/manual/en/latest/troubleshooting/gpu/common/other.html#wrong-selection-in-3d-viewport

It looks like there may be some possible fixes for your selection issue. Let me know how it goes!

No way to change it. Here’s a thread on Dev Talk on same issue.

last link is what i was talking about

not certain there will be something done about it !

first link is more about video card
my card has open cl 4 so works fine up to now with cycles

it is just that i saw the difference between 2.79 and 2.83
and i find it a bit annoying and distracting in 2.83

thanks
happy bl