Transparancy problems in game engine


(sonix) #1

See also previous post re Supa Monkey Ball,.

Check out my web page for images http://hometown.aol.co.uk/sonixsculptor/SLG1.html

I just get a white spere, when pressing P . My monkey(Suzanne) is inside the sphere, I’ve set the texture up correctly so I can see thru the ball to Suzanne in the render mode, but can’t work it for the UV.

Tried all possible buttons regarding Alpha etc, that I can think of, does anyone know of a way that works.

Also tried WIRE frame the sphere instead but I would rather have transparanet Ball.

(No one interested in this yet, as a small project?)


(S_W) #2

Did you texture your sphere in face select mode or in the material buttons?


(Fred_Pyo) #3

hmmm… (just in case) the material and texture buttons only work when rendering… you MUST use UV texturing for games. And to make your… (ball was it?) you must make the texture (TGA or PNG in blender 2.225) with an alpha channel… that will set the amount of transparency. And in the paint buttons, when selecting al faces you change from opaque to alpha…

Want details? Or I just explained something else?..

-Me


(sonix) #4

Tried using PNG, 24 bit, but still no joy, I have had the faces set to alpha, Tex is set to UV with Alpha in material settings, even made a new transparent PNG but still no joy.

What is I doing wrong?


(Fred_Pyo) #5

Alpha under the paint buttons? or Material buttons? huh?
http://guble.tripod.com/alpha.jpg (copy paste in browser)
That of the paint buttons should be the one
Remember to copy this to all faces selecting them all and then pressing copy drawmode[/img]

Not yet?

-Me


(sonix) #6

Fred, that’s the one, with F than A to select all faces, then select Alpha as in your .JPeg.
Check my web page for project screen shots:- http://hometown.aol.co.uk/sonixsculptor/SLG1.html

I have also tried using the invisible toggle, but I still get a white sphere, and can’t see ‘Suzanne’.

Also I select UV in the material settings instead of Orco, and Tex face, for colour.

Still no transparency joy when pressing P. Do I need a Python script or can it be done through button selection?
I have tried the methods suggested in the previous replies to these posts but still no joy.

Sonix


(Piraniac) #7

humm…really can’t think what could be wrong :-?
what image format are you using? 2.25 allows either TGAs or PNGs with alpha channels, but thats all. MUST be 32 bits (the extra 8 are the alpha channel).
Could you possibly mail me the .blend, or a similar test, i really don’t now what else could be wrong if you’ve done all the above posts :frowning:

hope something works out…

cheers
Piran


(KingJames) #8

Before I go into detail on how to do this, is this what you are looking for?
the round circle pictures are uv mapped onto the cube and are transparent, and what you see is a snap shot of a 3d window in shaded view.

http://home.att.net/~holywordkids/Transparent.jpg


(sonix) #9

King James,

Yes that’s the kind of thng I’m after. I think my problem lies in the 32 bit TGA/PNG files I need. I have a feeling they are only 24 bit at most.

Will try at 32 bit and see if this works, and can you repeat your method on a sphere or is it just restricted to a cube?

If you check the link in the top post, you can see my Blender settings and rendered output, it is a test tho.


(Piraniac) #10

any face can be alpha, no restrictions to certain shapes
the settings in the screenshot ‘should’ work if the image is mapped correctly using the UV editor, the material settings are pretty much irrelevant in-game

also, tested TGAs and PNGs myself, had a few problems getting the alpha channel in the TGA to work, PNGs were fine though so i recommend using them if possible

cheers
Piran


(sonix) #11

:frowning: Still no good.

Tried PNG at 32 bit, even tried with alpha channel converted, but no good.

When I select the sphere and press F, do I need to only select half of the sphere’s faces or all.

I add a uvsphere (should it be an icosphere?), around Suzanne, then press F, then load my transparent PNG as a UV texture. Then I press U in the main 3d window and select from window.

Then when I press P, all I can see is a solid sphere. In the vertex paint buttons, when F is selected ALPHA is selected instead of the default setting.

So what am I doing wrong. If I use the PNG with the converted alpha channel, all I get is a black UV texture, and then black solid faces.

Help me please.


(Piraniac) #12

blimey!
OK, this is starting to bug me now :-? I just don’t get why?

Have you tried a simple test, i think we need to identify whether it is the texture or the mapping.
Sorry if you’ve already done this but:-

new scene -> create a plane -> F -> U (Any mapping mode) -> load texture -> click Alpha in face buttons -> Alt Z
If this doesn’t work then its a texture problem
If you get a white face then it hasn’t mapped correctly

i know you know how to do most of that but hey, i’m bored
oh, and Alpha works on ANY face

cheers
Piran


(sonix) #13

Piran, cheers for the pointers.
Did you get my test blend files?

Tried your test with the plane and it works :stuck_out_tongue:

Then tried it on a sphere (UV) and no joy, so it’s not a texture or UV mapping problem, maybe it’s a publisher bug?

Any one else been able to do this for a sphere?

Thanks to all for the replies and help, keep blending

Sonix


(sonix) #14

:stuck_out_tongue: Piran, King James, all others who have helped me,

Just had a play around and have realised, that a sphere, or anything with more than one face, needs to have each face selected individually and then ALPHA depressed in the Face paint buttons. It will not work if ALL faces are selected at once.

This therefore means that it’s a ball aching process of selecting a face pressing Alpha then selecting the next face and repeating.

If all faces are selected then ALPHA depressed, no transparency occurs, do you find the same thing?

Does any one know of an easy (and quick) method for objects with multiple faces, to save the above method having to be used?

:stuck_out_tongue: Thanks again


(Fred_Pyo) #15

I said it before… :frowning: how sad you didn’t read my short post…

there’s this magical button “Copy DrawMode”!!! :smiley: :smiley:
To use it you have to select all faces… push Alpha… and then Copy DrawMode… :slight_smile:

Good… good…

-Me


(sonix) #16

Fred, sorry mate. I did read your post, but missed the copy drawmode part.

Is this a button, or do I press a key with the mouse over the 3d window?

Cheers for your help.

Sonix


(saluk) #17

It’s a button in the paint buttons. It will copy the paint settings from the ACTIVE face (in face select mode, the one with the red and green sides) to all the other selected faces.


(Piraniac) #18

Hehe… :slight_smile:
glad thats sorted, i got the .blend but hey now you can move onto the next part :wink:

keep it up!

cheers
Piran