Transparant from the outside only. (or camera view)

Hi,

I’m trying to recreate this still as an excercise:


hp: http://www.winosi.onlinehome.de

You may have seen it been discussed here: https://blenderartists.org/forum/viewtopic.php?t=36509

The problem I can’t figure out is how to get the two transparant faces (facing the camera), that reflect as the green and the white in the sphere, (wich are seemingly not transparant from inside the room)

The blend file from Samjh, in the thread above, did’nt help me much as he was cheating :stuck_out_tongue: , removing the white face and taking the 3d still from another angle. Actually made me think it’s not possible with blender, so I ask here.

bump…
come on, someone must at least have a clue about this :-?

Maybe rendering the scene with the walls and using an envmap instead of raytraced reflections for the chrome sphere? Then remove the walls and don’t refresh (“Free data”) the envmap. I don’t know if it would work with the transparent sphere. If it doesn’t work, maybe you could bake the envmap to a uv-map with Python (have no idea if it’s possible) and apply it as a color map, and lower the opacity.

For some reason I’m not exactly sure what you’re trying to do. You want to be able to see through the walls like above? Or am I missing something?
You should be able to just flip the normals, and make sure it’s one sided. If that’s what you were talking about anyway. %|

Hmmm, I just tried to recreate the scene, but it’s not working as I had though it would… :x

Is this a bug in Blender? Single sided face with normals pointing away from the camera should be invisible (or at least they are in the other 3d program I know of). But in Blender they are rendered black, so in the bottom line they are still double sided but not properly shaded on the backside. So what is really the use of the “Double Sided” button as it is now (when disabled)? I can’t think of any. :expressionless: