Transparency-2.8.2a-What is the easiest way to make an object partially transparent without shaders?

What is the easiest way to make an object partially transparent without shaders? It looks like the Transparency checkbox from the Viewport Display area has been moved/removed in version 2.8.2a…

I’ve followed several tutorials, changing the alpha channel of the Material’s Base Color in the Material Properties tab, Viewport Display, toggling between the Material and Object Color selector in the Viewport Shading window, etc. Enabling Alpha Blend or Alpha Clip, to no avail. I’ve tried both Eevee and Cycles.

Whatever I try, as I drag the alpha value, the object will instantly disappear completely at a certain point, like a clipping level has just been passed. I cannot get a partial transparency/opacity.

I am just trying this with basic Cube mesh objects, and just looking for the simplest method for creating partially transparent objects in the Viewport and when rendered.

I set the viewport to studio and object color. I changed the object color alpha.

Most of that implies shaders but you started off saying you want to do it without shaders. I’m confused.

You have to tell Eevee how to handle transparent objects and transparent shadows explicitly. This is done in the Settings Panel under the Material Properties. You have to choose whether or not you want backface culling, you have to choose your object Blend Mode and your Shadow Mode. I’ve provided an example below:

Thanks for your response. I’ve tried exactly what you said, by I keep having the issue where the alpha isn’t fading smoothly, it’s just an on or off at a certain level (clipping). When I said I don’t want to do it with shaders, I just meant to be able to do it in the object settings window, like you did, as opposed to going into the shading window and dealing with the nodal materials editor.

Thanks for your response, I’ve tried what you suggested, but I still get the same results of the alpha just clipping on or off, no blend.

What Hankadoodle said should work. Make sure to do the second thing he circled which is turn the Blend Mode in the material to Alpha Blended or Alpha Hashed.

I don’t have any issue in 2.90…

So, there are some things to do. First, watch the video below and make sure you are doing the same things as in the video. If you are following those steps exactly and you are achieving a different result, there are a few things that could be happening.

  • It could be your file. You can help troubleshoot that by uploading your file and we can see if we have the same issue on our end. If it is your file, you may need to reload your factory settings. To do this, go to File > Defaults > Load Factory Settings. Be warned that this will reset your preferences.
  • If it isn’t your file, it could be your Blender installation. If there was something corrupt in your settings or your install, you might have the issues even if your file is confirmed to be good. You would then need to reinstall Blender (and possibly reload your factory settings, as well).
  • If it isn’t your install, it could be your system. You may have an issue with your graphics card or driver that is affecting how the cube is being drawn. If there were an OpenGL issue, I would like to think that Blender would be throwing errors, but I’ve experienced issues without an error in the past. (This cause is unlikely as you said you tried both Eevee and Cycles, and Cycles wouldn’t suffer from drawing issues the same way Eevee does.) You may need to update your graphics card’s driver or at worst, a new graphics card.

After all of that has been worked out, and if you are still having issues, you may be out of options for the viewport. Your only hope at that point would be to render your object from its background separately and composite it back in with transparency. If it comes to that, we’ll talk more about collections, view layers, shadow catchers and compositing nodes.

Let us know how it goes.

Thanks again for your response and sorry for the newbie question. It turned out to be a combination of me trying settings in both Object Mode, Materials Mode and the stupid mistake of adjusting the Alpha in the Object Base Color, instead of the separate Alpha in the attributes list where you did it. All good now! Thanks again.

Glad I could help you find a solution!