Transparency in 3D view on material?

Hi,

I have a uv texture applied to my objects with an alpha channel set up. It works in the render, but in the viewport it adds this annoying white fill. Any idea of how to get rid of it? Here is my set up:


Hi

Your settings looks right…And You are in Material view…So it should work…?

A few time I have seen transparent file do not work… I don’t know why… Try to use another transparent file to see if it change it.

Or upload the Blend file so other can have look at it.

Ps

Just did a test if You use - add mesh - Images as plane - it work…But look left side in browser when You select Your image…Maybe You have to Tic some options…Below materials - Diffuse + Transperant.

would like to know why it don’t show when I set the node manually…But what I’m a Noob…)

Cheers

Tai

What do you see with image in UV editor when you click last button - b/w square?
If that is a fully white rectangle Blender can not find alpha channel in your image.

Hi

Yea I have the white retangle.


But what did I miss - node setup is same as when I use Images as plane…?

It’s the same texture…Why can’t Blender see it…:slight_smile:

Tai

Is it me or has “Cycles and alpha” become an increasingly funky combination?
Even when the UV/Image Editor shows the alpha in images I get the white rectangle in Cycles’ material view - until I set up the material correctly for Blender Internal. Switching back to Cycles it suddenly works there, too…


you need special goggles to see it !LOL

seen it before but still a mystery

happy bl

Same here. I almost went crazy trying to achieve transparency in Material view in Cycles.
So to get transparency I need to switch to Blender Render and tick “Transparency” in Material Tab under Render Pipeline Options.

Do you know if this has already been reported?

I can not find anything related to cycles and transparency in textures, except this https://developer.blender.org/T43779
Maybe it’s not reported yet.

So, should we report?
Or this will not be considered a bug?
This seems an old issue.

Thing is, i could not come up with “this fails 100%”. I was pretty sure i’ve found “golden combo” - alpha export settings from Gimp for Blender but then it would suddenly fail on occasion not just for some random but for created by me simple image file.
Issue i linked from tracker is an old one - usually pixel wide transparency around the image helps.

report if you can repeat it
otherwise I guess it will be canceled

happy bl

Can you tell me if this is a good file to be presented in the report? Are the nodes properly configured?
http://www.pasteall.org/blend/37183

The image is png and has alpha channel.
At least doing what I’ve said before with BI, I can see the transparency in Material view.

Edit:
Maybe this node setup is better:
http://www.pasteall.org/blend/37186 << Edit: this file is not well configured

Edit 2:
Ok, I found this:
https://developer.blender.org/T44826

mentioning Game engine, but I think is related. But the problem that is mentioned there about the objects behind transparencies are not correctly showed does not occur if the modification is made in Blender internal. I think I’m going to report it anyway

Here transparency is working in both files - straight out of the box. I did try export image and then import image as a plane for Cycles in a new file - this also had no issues :(.

@eppo, on the left screen, in 3D View? I can only see transparency in UV editor.

That’s weird. So it works for you and does not work for me. According to the rules this can not be reported.
All I can do is share more data so it may be useful to find a pattern of the problem:
Kubuntu Linux 64 bits
nVidia 352.21

I found file with the white in viewport texture mode

you want it ?

happy cl

@RickyBlender, I do not know. Does that affect in some way the Material View? Can you see the transparency in the 3D View on the left screen with the files I shared?

Edit:
You should only see the star in the center if the transparency is working

@YAFU - left, 3Dview. Nice white star, transparent around. UV editor alpha view shows mask which does not happen when there are problems - it’s fully white then.


I see this but cannot see transp in viewport I guess

my file is like this


happy cl

Transparency in Material view is not working for me. With the second file I share, in Material View the alpha channel is shown as solid black. When I make the changes in BI and return to Cycles, the transparency is working in the alpha channel (I can see the star with transparent all around).

I wonder if IkariShinji is having the same problem with my files.

Edit:
@RickyBlender. Yes, that’s how I see it in my file. When I make the modification in BI and return to Cycles, then transparency works.

see post 19 my file show white instead of alpha

happy cl