Transparency in game, using just a plain color no texture?


(Social) #1

I was wondering if there is any way to achieve transparency in the game engine with just a plain color (lets say gray)? I dont want to use any textures, (I know about using the texture alpha channel to achieve transparency, but thats not what I want). Im sure that the blender game engine can do transparency for just a flat color, without importing any textures, but how.

I was searching for a tutorial on something like this, but had no luck. If you know of one, or could give me detailed instructions on how to do this, I would be very greatefull. Thank you.

PS: I asked this question once before and I remember someone giving me instructions on how to achieve invisibility. Just want to clear up that I want “Transparency”, which is to be able to see through something, but still being able to make out what you are looking through.


(z3r0 d) #2

you need to have Tex selected [even if no texture is assigned] for alpha [use obcolor to set the opacity, unfortunately this means you can’t use vertex colors] or add mode faces to work.


(gorgan_almi) #3

Or if you want to use verex colors as well you can create an IPO with just one keyframe that sets the alpha channel (ColA). :slight_smile:

Keith. 8)


(Social) #4

Could you please elaborate? If you could tell me step by step it would really clear things up for me. Thanks.


(z3r0 d) #5

in face select mode, instead of assigning a texture hit just the tex button

your faces will probably turn pink, but in the game engine the alpha or add settings will work [and your faces will not be pink]


(Social) #6

That did not work. The object just turns completely white whenever I go in faceselect mode and then come back to object mode.

Could you give me an example of an in game flat color - transparent object? Maybe it has something to do with my pc.


(Dr S) #7

You should be able to set the face for “tex” and “Alpha” and not have a texture mapped but in 2.37a I seemed to have trouble. always came out pink. the easiest fix was to use 64*64 blank tga to map to. Still had to pack a texture but small file size

Dr S


(Social) #8

Actually you can make it transparent if you have your vercol set to something other than white and than hit tex, add, copy draw and it turns somewhat transparent. It looks real buggy and you cant even see your object if your background is white, so I decided not to use transparency in what Im doing. Also I have found myself “jiggling” the texface buttons just to apply something simple as a vertcol, very strange.

Thanks for your input though, Ill try what you did just to see what it looks like.


(z3r0 d) #9

even if pink in the 3d view it will show up correctly in the game engine

you can use alpha without assigning textures


(gorgan_almi) #10

Just do it the way I suggested! it works fine!.

Keith. 8)