Transparency in Minecraft Animation Showing as Black in 3D View (screenshot)

So as you can see in the picture, the transparency around the sapling is rendering as black. I’ve been trying to solve this for a while now. Does anyone know why this happens? I set Alpha to 1 and DVar to 0 (exactly.) My current transparency setting is Z-Transparency. Here’s the screenshot (http://i.imgur.com/dNjyW2h.png):


I assume you’re in Multitexture display (in GLSL display it should not happen, if you want to change the display, in the 3D view press N then scroll down until you see the display tab in which you can change the display mode).

Usually the transparency turning black in the viewport happens in Multitexture display as soon as you add a material for the model, as long as you don’t have a material, the transparency is existing if you assigned the texture through the UV/Image Editor .
So even if you setup everything correctly, as soon as a material is assigned, the transparency is turning black

I reported this , but the devs rejected it and so in Multitexture mode for reason i still don’t understand, you will have to go through those extra hoops to fix that :

  • select the model affected by the black instead of transparent part
  • In the top header of Blender, where it says “Blender Render”, click on it to change the mode to “Blender Game”
  • In Blender Game mode, now go to the Material panel, and see a panel named “Game Setting” that does not exist in the default “Blender Render” mode
  • In this tab you will see an entry “Alpha Blend” that by default is set to “Opaque”.

It’s what is responsible for the transparency turning into black.
Instead of “Opaque” set it to another mode and you will see the black becoming transparency again.

You can now go back from “Blender Game” to “Blender Render” mode in the top header.