Transparency in Textures????

So when I apply a texture to an object this is what I do:

  1. Create the object as desired
  2. Mark Seams where they need to be
  3. Select all the faces and hit Unwrap
  4. Drag and drop a texture into the UV/image editor.
    (I can now see my unwrapped object overlayed on my texture.)
    Then in edit mode I go to Display -> and check “Texture Solid”

At this point my object appears with texture but the pieces of my object appear and disappear. As though they are transparent from certain angles. I have attached examples of what I mean. The view of my object from three different angles with different panels missing in each view. This is supposed to be a cube like object.





Any ideas on why this happens?
By the way I’ve already checked my normals. That doesn’t fix the problem.

Thanks!

Your object doesn’t have a material and the texture viewed from the UV/Image editor includes a transparency.
The normal procedure to have a texture on your object when rendering an image out is to assign a material to it and then a texture. In your case:
-Add new material (materials tab)
-Add new texture (textures tab)
-Texture type: image or movie
-Load an image or select one from the list if you already have it in UV/Image editor
-Under mapping, coordinates: UV

There’s also texture shading mode on the 3D view header (hotkey: alt+z). Textured solid means it shows the texture in solid shading mode, but you do want to have GLSL selected in the dropdown menu just above that textured solid setting. You also need a light for the texture to show up in the viewport. Hemi type light works best in the viewport when you’re checking textures.

N-panel, View. What is your Clip Start value there?

check your normals

if reversed it wont appear in viewport or render !

also check you clip distance in viewport

salutations

I checked my normals and they looked fine but my object did not. It’s really weird

My Clip says Start: 3.937" End: 3280.84’

Thanks for all the help guys!

turn the clip start down to more like 1, your clipping parts of the model too close to the camera. Also note that view camera clipping and render camera clipping can be different, make sure your altering the correct one!

Hi there,

I am using cycles render. I want glass material to be semi transparent in the viewport. how to do that?

I know how to setup semi transparent material in the viewport using blender internal material setup, but not cycles…