Transparency in Viewport

Hi Blender community,
I have game textures with an alpha and want to see them with their transparency in the viewport.
Before, I just assigned textures in the UV editor in textured solid, and transparency worked.

However, I need to use transparent materials for technical reasons and can’t get it to work in the viewport.

I’ve tried:

  • being in GLSL, in material view
  • checking transparency in the the Display of the object
  • checking transparency in the material
  • the use alpha is checked in the image - texture tab
  • checking and changing the numbers in the alpha (influence, in material tab)

Can anyone can help with that simple, but often asked problem? Please please please

Thank you

Viewport shading to material, material -> transparency: alpha: 0, material assigned image texture -> influence: alpha: 1. That way the image alpha transparency influences material transparency. If you also want color, check influence diffuse color and have a light source in the viewport.

If that doesn’t work, instead of replying with “it doesn’t work”, post attachments. Namely an example .blend with the texture packed in.

btw is it me or transparency in viewport doesn’t work for linked library objects?

It did work! I fiddled with those options independently, but not together. Thank you.