Transparency issue

I have spent a little time making a eyeball for a future character. However, I can’t seem to make the cornea allow light to pass through it.

This is the eye. The half sphere above it is the cornea.

Here are my settings for the transparency

Issue being, when I render I end up with something like this

Does anybody know how I can make light pass through the cornea to hit the blue iris? The only way I’ve been able to have the iris visible is to make the iris material shadeless. But I would prefer not to do that.

I’m pretty sure the answer is right under my nose, but I haven’t been able to pin it down…

Also, How would I go about preventing a shadow being cast from the cornea? Is this possible without modifying the lamp? I suspect this is the issue…

Thanks in advance!

For objects receiving shadows from a transparent object you need to set ‘Receive Transparent’ in their Material / Shadows settings

Awesome! Thank you