Transparency Node Setup in Blender Rendering

Hello,

I am using Blender rendering, not Cycles rendering. I’m trying to find a setup in node editor where I can make one of 2 colours in a texture become transparent. The problem is I can’t find a way to make an object transparent using the node editor. I have no clues. I have tried everything I can think of. I know the basic on how to make an object transparent without using node editor.

Why would I use node editor, not using the basic? Because I have a texture that I baked from using cycle rendering. Texture has red and black… I want to make that “black” become transparent. The basic only use texture composed of just one colour and background with alpha. that’s it.

if you have any questions, then please ask me and I’ll answer as soon as I can. This way, we can find a better solution to solve my problem. So thank you for taking your time reading this topic and my problem. I would appreciate your help with this.

Enabling nodes will add a panel in material properties called “render pipeline options”, enable transparency there.

It’s Cycles, not cycle.

sigh…I see. that doesn’t solve my problem. I am using internal rendering, not Cycles rendering. :disappointed:

Obviously the nodes have to make a grayscale mask for alpha and drive that material property. Might be able to just take a math node set to greater than, value 0.01, and use that. If not, could also try color mix node set to difference before that, or just multiply and clamp the values to make the red full white, where multiplying black will stay black.

:thinking: is it alright if you can make a screenshot of what you’re talking about. I am a beginner in internal rendering.

sorry to trouble you with that :sweat_smile:


In this one I’m using the color difference to pick a color that’s not black. If the alpha color is black, should be able to connect the texture directly to the math node.

Alpha can be connected directly to the output, or run it through an extended material and connect its alpha to the output.

:sweat:

I knew it has to do with math… that math was the answer to change the color into transparent. I learned that from doing experiments. I ended up running out of ideas. so thank you for helping me out. I am going to use that idea. I’ll let you know how it went.

Can you explain about the extended material node? it seems that I am not sure how you used that.

edit:
@JA12
Never mind, I figured it out how you used the extended material node. so I’ll give you the png and see if you can do something about it. The math is not correct.

as you can see, there are a mix of 2 colors. red/brown-ish and black. The PNG are used for a freight train car I was working on. The PNG was to make the train look dirty and rusty.

There must be information missing

This is the problem my suggestions are for:

And

This is my last reply to this thread.

Alright, Thank you for helping me out.

your suggestions are very good, but the problem is that the math look like it doesn’t remove the black completely. I’ll keep playing with the math until I find the right one.

have a great day.

I’ve figured it out how to get it right. BUT I ran in one problem. It’s better to show you a picture:

You can see the colour on dirt/rust texture is not showing the correct colour. I think it has to do with transparency. :thinking:

is there a way to fix this simple problem?

If i understand what you expect to see in your last picture, you don’t want transparency

You want color mixing!

Your question is badly formulated, and absent of examples and a blend file… that doesn’t help to get good, quick and consise answers here… :confused:
In other words, if you want to mix the rusty color to another color based in some value (could be color intensity, or alpha, you name it), and not making the object transparent that you can see throught, than you should take a look at Color->MixRGB node.

I apologize for my messed up explanation in the first post. You misunderstand.

In the pictures, I created two objects of the same objects. The second object is slightly bigger than the first object.

Object#1 has red colors
Object#2 has the rust & dirt body (that’s why I made it transparent)

so you put Object#1 and Object#2 together in the same room, then you could see the red through Object#2 as if it’s glass but the rust&dirt are not transparent.

What I want to know what was the cause of why Object#2 color is mixing with Object#1 color. I don’t want any mixing between Object#1 and Object#2. That’s all. that was the problem.

sorry about my explanation, I’m not very good at explaining.

That’s a strange way of doing it… I advise you to use just one object and mix textures for the material (the red and the rust/dirt colors)

For using the method you’re using you need to make some changes in render settings, material settings, etc.
First, the transparent object must have the transparent map in the texture_panel and not in the node editor. This will let you enable material_transparency and set it to ZTransparency or Raytrace. (ray tracing option in the render tab->shading should also be On)
The second object must have receive transparent on, in the shadows properties (or you can turn off the traceable option in the transparent material, which will disable shadows for the transparent object).
Then you need to be carefull with ZBuffers conflicts…

This is however a very clumsy way to work, and gets even more limited if you want to make more complex texturing in your objects.

Alright, I’ll look at the setting and see how much of improvement it will make.

but it’s not strange as you may find it to be. It’s pretty much common way to get around the limitation of format I want to use for exporting the model to… OBJ format doesn’t allow multiple textures or UV maps, so you can only use just ONE UV map and texture. that’s it.

There is another format I am aware of. FBX format can allow multiple UV maps and textures. I have a good reason why I must use OBJ format is the game I want to add my model, so I can play or test to see how it look like in the game. The game required me to use OBJ format, not other formats. Honestly, I had no idea there are limits that other formats would have until a few days ago.

Anyway, thank you for sharing what you know and I’ll check it out.