Transparency of Image Empties does not work - OS X

Hi there

In the image below you can see that the selected right empty shows the transparent image correctly while the not selected right image does shoe the the scene grid inside the transparent background but the 3D model is not visible.

Is that a bug in the OS X version or does it work this way on purpose?


Never seen that happen before.

If you want to attach a blend file i can see if it works or is different on windows.

Powerst

here is one: http://cl.ly/3a2z0W1o1G3Q

For me with that test blend you posted, if I have the image plane selected then it is properly transparent. If I select anything else then the image plane is not transparent.

Playing around with it now to see if i can figure out why it’s doing that.

I have no idea why it’s doing that. I’m guessing it’s just some weird OpenGL thing with how the viewport is setup. But it definetly does the same thing in Blender 2.66 on Windows 8.

You can just set background images for your viewport if that works for your situation. Not sure if there’s any particular reason you used Image Plane instead of just setting them as background images on your viewport. Here’s how to set them as background images if you’ve never done that before.

Here’s what i did with the images you provided. In your viewport press ‘N’ to bring up the right side menu. Go down to “Background Images” and check it.

Add 3 background images.

First one: Use “Front.png”, Axis to “Front”, Size to “.035”
Second one: Use “Top.png”, Axis to “Top”, Size to “.035”, y offset (Under back/front buttons) to .020
Third one: Use “Side.png”, Axis to “Right”, Size to “.010”, X offset to “.005”

You can set them all to display in Front of the objects instead of Back. Then when you go into Front, Top, or side view using 1, 7, or 3 the background images will show.

May need to change the drawing so the lines aren’t blue on top of your blue mesh though, makes them harder to see.

Hope that was helpful.

1 Like

Hrm… Just noticed you have over 9,000 posts. You probably know how to setup background images.

Sorry about that.

Oh, found a workaround.

Select your image plane with your drawing on it. On the object properties under Display set it to X-Ray.

For me that’s showing the transparency on it properly even with other objects selected once you set the plan with the image to X-Ray. It’s just something weird about how OpenGL renders a transparent image on a plane like that.

Let me know if that works on OSX as well.

1 Like

Hi powerst,

duh yes I have over 9k posts but sometimes forget the obvious infront of me. Well I think the alpha issue is a bug and if not a bad design. However your tip with the x-ray makes this work of course - grrr should have figured that out on my own.

Thank you a lot!!!

EDIT: 2.58 log: so no bug that feature simply is not build in and needs to be done with x-ray!
Empty Images Display:http://wiki.blender.org/uploads/thumb/c/c6/Changelog_2_58_empty_image.png/160px-Changelog_2_58_empty_image.pnghttp://wiki.blender.org/skins/common/images/magnify-clip.png

Instead of using background images or creating meshes with materials and image texture it’s now possible to assign images directly to empty objects to use as reference images. They display in all draw modes and can use object draw options like XRay to draw over other objects.

Happens to the best of us. Glad you got it working.

it works a little however even with the x-ray function now the images block each other lol …

I joined this community so I could purely like your comment!! I’ve been frustrated with this for a long time.