Transparency Problem - Any Ideas?

Hi everyone, I’ve recently created a meteor and the Earth in Blender after following some tutorials, and I think it’s looking pretty good. However, when the meteor passes in front of the Earth in the animation, the Earth can still be seen through it:

http://th00.deviantart.net/fs70/PRE/f/2013/026/3/3/problem_image_by_andydaroo-d5ss5a4.png

In the scene, the meteor is in front of the Earth, which is in front of a plane. The meteor does not have any “Transparency” settings on, and there aren’t any other obvious settings I can see that may be causing the problem. I’ve also used compositing nodes, with the Earth render layer and meteor render layer both going to ‘Add-Image’ then to ‘Composite’ and ‘View’. Could that be the issue?

I can post more settings if they’re needed. I’m still a bit of a novice in Blender, so any suggestions as to why this is happening would be very much appreciated! :slight_smile:

Would be nice to see your node-setup but i guess you mean that you are using a colormix node with the option add. As the name says the values of the pixels get added so you end up with this transparency. Try using a alphaover node to combine your renderlayers. You need to set either sky to alpha in blender internal or film transparent if you are using cycles render engine. You can also take a look here: http://wiki.blender.org/index.php/Doc:2.6/Manual/Composite_Nodes/Types/Color#AlphaOver_Node

That worked great, thanks very much! Especially for the quick reply :slight_smile: