Transparency problem, help is welcome...

Hi all,

First time ever I use transparency. Please look at the pictures below.
The transparency is weird, and I don’t know what happens.
(I don’t know whether this is important but I am exporting the mesh (.dae or .obj), no animation, no rendering.)
Here is the scene with no transparency:
https://blenderartists.org/forum/attachment.php?attachmentid=444640&d=1468413062&thumb=1

And the same scene with transparency (about 0.5) applied to the 2 legs on the right:
https://blenderartists.org/forum/attachment.php?attachmentid=444642&d=1468413149&thumb=1
Some faces look darker than others…

A small video to see better how it looks when moving the mesh:
http://screencast-o-matic.com/watch/cDiIlhiaXx

Any advice ?
Thank you for your help

that is only viewport showing this
but may do same thing in render
depends how many faces are in line and angle I guess

happy bl

Hi RickyBlender,
Here is how it look when rendered, kind of a wireframe mode… I am surely missing something here
Any idea what ?


kind of strange in this in bl or cycles ?
can you make small sample file and upload with just the legs so we can look at it

happy bl

Hi Ricky,
Looks like the “backface culling” option is solving this problem under Blender.
Now my problem is that it is certainly not written in the exported COLLADA or OBJ format since viewing the legs under Sketchfab is still a problem.



I guess you have some transparency material then !

check the mat and texture in bl !

happy bl

Hi RickyBlender,
well if you want to have a look at the Blender file and tell me what you think.
Thank you
https://www.sugarsync.com/pf/D7911250_06095005_958557

look in your mat panel
you have transp set on

remove it and it wont show as transp mat !

also always save your file with compress set
and if possible zip it to make it as small as possible

happy bl

Attachments


Well, I know that, I did check this transparency box myself. Maybe I did’nt explain well but what I want is to export this transparent mesh as if the “backface culling” was ON. Right now, when exporting, the mesh behaves like this when viewed on Sketchfab for instance.

https://blenderartists.org/forum/attachment.php?attachmentid=444952&d=1468651403&thumb=1
Can I have backface culling-like written into a COLLADA or OBJ file ?
Thanks

I don’t think at all this is possible
backface culling is more a specific viewport effect then a mesh data!

happy bl