Transparency, shadows & backgrounds


I have a detailed newbie question for y’all. I can’t seem to find a tutorial and/or prior post that spells it out clearly enough for me.

I have an image background-- a scene of a flat grassy park. I want my ship to fly down out of the sky and land in the park. I can do the ship animation just fine. But what I can’t seem to get is how to have the ship cast a shadow on the grass.

I thought it would involve creating a plane, angling it to roughly match the lay of the park and somehow having it be transparent EXCEPT for the ship’s shadow… but I can’t get it to work.

Could someone layout the step-by-step for me?

And of course, ultimately I would want to replace my background image with a background video… which I understand is a bit trickier?

Thanks in advance!

Weirdhat has a tute on how to do this. Check his site. You can get the link from the member list.


Make a plane in the background. It should cover the whole camera view. Then Give it a material and the texture of your background image. Make the texture a “win” texture and make it shadeless.

Give your shadow-plane a material and activate ztransp and only shadow. Now all you need is a spot and your ship.

thanks for posting. I didn´t try this before.


i don’t think you need to fill the whole backround with the plane.just match it with the grassy plane of the picture. this can be very troublesome.

the plane that carries the shadow doesn´t have to . But the plane with the background video should…


Thanks, guys,

I read through Weirdhat’s tutorial, and tried to replicate it …

I decided to skip the ship for now, and just try to get a sphere to drop a shadow in my park-scape. I have the sphere floating in the picture, and the park looks fine… and the plane I made to drop a shadow on is there, with a spotlight on the ball… only thing is, I get no shadow! I know there must be something simple I’m overlooking. Perhaps someone could take a gander at my file and tell me what’s up?

My blend file is loceted at


Mikeman: yoProblems with the blend, in order of appearance :wink: :

  1. Spotlight is not poiting to the sphere. Move and rotate so the direction line, (is that what you call it?), points through the sphere.
  2. Only make the “SpotSi” setting between 60 and 80. Typically always.
  3. Make the distance of the spot large enough that it goes past the plane.

This should solve your problems.

Post your email and I can send back the blend file for you, if you want. Try what I said and see if it works. :smiley:


PS: Here is a link to the image that I did with your blend file. Hoep that is OK? :wink:


Worked like a charm! Thanks!

The problem here was my lack of understanding of how the spotlights work… I thought the spotlight pointing in the general direction would work… wrong. After reorienting the spotlight to pass through the sphere, I parented it to the sphere so as I flew the sphere around, the spot stayed on it-- looks great.

Thank you again!

There is a trick with constraints:

If you just do some tests and you don´t care about a sun following your ship then try this:

Name your ship (or the sphere) ‘pedro’
select your spot
go to the constraint buttons
add a ‘trackto’ constraint and use the name ‘pedro’ for the ‘ob:’ field

now your spot will always follow your ship.

This works fine for lighting, too (if you use an empty instead of Pedro). The focus will always be the empty.

But this parenting is also a nice solution. Simulates parallel lightbeams very well.