transparency


(DAK) #1

I have one texture and I want the object to blend in gradualy with another (one object on top of another). I used a gradient and set it to alpha, but when I render, the gradient becomes darker than the two textures and does not blend correctly. I assume it is because the alpha is altering the reaction with the light. Is there a work around for this, or option I over=looked?


(SKPjason) #2

How about the “blend” feature in texture settings…


(S68) #3

I assume that you pressed the Xtransp button, right ? :slight_smile:

Stefano


(DAK) #4

The blend feature looks like it only makes a gradient map. I already have a gradient map. But it is the gradient part that causes light to hit it less.


(theeth) #5

that’s a completly normal behavior, since the object behind is not light by the spotlight, since Blender’s shadowmap calculation doesn’t take into account the alpha value of the material. You could disable the first object from blocking the light by unselecting Traceable in the Material Buttons.

Martin


(DAK) #6

I tried this and it did not change. Even if I just have one object, and use a background image in the backbuffer, I still get dark bands in the gradient instead of a nice joining blend with the back buffer and my object.


(Free Mars) #7

Try this.

Put each object on a seperate layer.
Put a complete set of lights on each layer with the objects.
Each set of lights should only illuminate the objects on their own layer.

Don’t know if it will work but it’s an idea.


(stephen2002) #8

humm… sounds like a rendering problem. I am not sure, but you may not be able to fix it.

Check the material preview window. If it looks like you want it to there, I don’t know what the problem is. Make sure that you have the gradient texture effecting the Alpha of the material and make sure you have “Ztransp” selected.

You can also try the Unified render (or if it is on, turning it off) and see if that fixes it.


(DAK) #9

Yes, I think it may be a rendering problem. The preview materials works fine but the render shows different results.