Transparency

I am trying to make some of my objects fade out from a scene. I have looked at several tuts from this site, but none of them seem to be working.

The object have specular highlights and shadows. Is there a good tut that shows how to make an object fade out? So far I can get the object to fade away, but the shadow still remains. It’s driving me nuts.

Any help is appriciated.

Thanks.

_t

ok. out of curiouisty i came up with one solution. i hope this is what you are looking for.

  1. select the lamp that is creating the shadow and duplicate it.
  2. both both lamps should occupy the same location(space).
  3. The rename one of the lamps to “Ray shadow”
  4. and the other lamp to “energy”.
  5. Select the " Ray shadow " and turn of the Ray shad button. as a result this lamp does not cast a shadow
  6. select the lamp you named “energy”
  7. go to frame 1
  8. make sure you mouse is hovering over the lamps panel and press key I
  9. in the pop up menu select energy
  10. got to what ever frame you what the shadow to disappear
  11. reduce the energy for the lamp you renamed “energy” to zero.
    to test your results
    go to frame one
    press F12 to render. you should see your object with the shadow
    go to the last frame where the object and the shadow should disappear press F12 both the should disappear . what providing the lighting is the lamp that does not cast shadow.
    hope this helps
    :smiley:

Or simply create an IPO curve for the alpha of the object.

Make sure you have TranShadow on to make the shadow disappear.

EDIT: oh, you know how to make an object disppear. Make sure the TranShadow button is pressed, it will make the object (like a plane the object is over) recieve a transparent shadow based on the alpha of the object casting it.

Actually, the alpha issue was complicated by the way the material was setup (I work with shotsy247).

The final solution involved setting IPOs for the alpha, Ambient, Specular, Specular hardness, Specular Transparency, Raytrace mirror reflection and default value for the texture mix.

In addition, transparency had to, of course, be set in the Draw panel (F7) for rendering, and ZTransparency had to be on (this was the indicator that something was wrong with the material setup). Toggling the ZTransp had the effect of turning what had been a “normal”, non-invisible looking material into a glass-like material. This was really puzzling!

But here is what that issue was about: the material had a Blending factor for the fresnel set to 5. When the Ztransp was toggled on, the material turned to a semi-transparent glass looking material. Once that value was set back to 1, the material looked and behaved as expected and looked “normal”.

Interestingly, it was not necessary to toggle the TranShadow on (???), nor was it necessary to Map To the Alpha or Specularity (this is opposite many of the tuts out there).

Anyway, although this was frustrating, it only shows how much control you have over material in Blender (eg, Blender is the bomb!).

Thanks for the great replies and different approaches! (eg, Elysiun rocks!). 8)