Transparent and Mix Nodes not working for me

Trying to make an object fade away in my scene. I added the mix shader and the transparency shader and connected them properly but when I reduce the alpha to 0 I get a flat black color where the object should be. Bit of a noob so if anyone could help me out it would be greatly appreciated. Cycled render if that helps.

edit to add i also have the blend mode in settings set to Alpha blend.

Can you share a screenshot of your node setup and material settings? And are you sure you are in Cycles? (those blend modes do not appear in Cycles).

Definitely rendering in cycles

link to node and material set up

I could reproduce the issue by reducing the number of transparency bounces:


mine is set to 8 currently and this is what it looks like

here is before I lower alpha

and thanks for your time with this

it worked thank you I had to crank up transparency bounces


1 Like

Glad it worked! And nice scene, btw.