Transparent background for texture on object

Hi there.

I am using Blender for 3-4 days, and I thought that I’m skilled enough to make some scene for minecraft animation. And here one problem appeared. I have a glass block, which has to have transparent background. In PNG with texture it is transparent, but Blender makes it black, but as I seen rendered block on renders it is transparent. On screen it is almost that what I want, but I see it’s a little bit darker, like smoked glass, but I don’t want this. Can you tell me guys how to fix it?

Thanks for reply.

Link to screen:

PS. On screen there is an Alpha transparency set on 0.5

Turn on premultiply in the textures tab, you have to do this to use alfa Chanel for any image texture.

If you are trying to recreate Minecraft ingame look note that there are no fractional alfa values.

Hmm… I turned it on, but still it’s darker. I turned off transparency, and I see that this black background is still on this block. And this background I want to erase. Do I have to do something more after I turn on this premultipling?

@EDIT. Bayley, if you are so experienced in creating minecraft animations, or just you know how to create this block, can you write a short tutorial how to make it from a scratch?

I have never made a minecraft animation, but the process for doing so remains constant for any blender project (Although I have played Minecraft).

“on renders it is transparent”

So the render is fine (Sorry for not picking that up the first time). What you see in the 3D view is never going to look just like your render. The reason being many effects are turned off in order to prevent system slowdown, for you at only 3-4 days it is no issue, but in more complex scenes one frame of a render can take anywhere from 1min all the way to a number of hours.

To view alfa in 3D view, select you glass block, go to the Object tab and enable Transparency under the display group. This will make alfa visible in the 3D view (But only for that one object!).

Do ensure that in the materials setting for your block have transparency turned off, that value effects the entire texture, not just the alfa chanel. And as before, the texture must have premultiply on.

As for your request, do you mean a tutorial for just making the blocks or for everything? You wont get very far if you don’t know how to make a block, specially since it is the default object in a Blender scene. I will warn you that what you want to do will turn out much more difficult than you are expecting it be. The best I can do for you is tell you how to make a glass block, and supply a useful link.

Noob to pro is one of the most complete (But not entirely finished) tutorials that will teach you right from an absolute beginner, into intermediate usage. It is a free wiki book developed by volunteers, I recommend it to all beginners. Some of the images used are from v2.4x of Blender, but the information is still relevant.

As for the blocks…

you need to create a cube (Shift-A)
then open a new window (Drag tab on top right of view to make new)
open the UV image editor in this new window.

Go to edit mode on your cube
Edge select 3 of the edges on on of the faces of your cube
Go to opposite face and select edges directly across from the ones already selected
Then where there is a gap (Because you only selected 3 or 4 edges on the two faces) should line up. Connect the ends of the gap on each face by selecting 2 more edges between the faces where the gap is.

Unwrap your model (Ukey)
It will then be visible as a flat image in the UV editor.

Add a material to you cube
Then add a texture
Set texture to be an image
Check premultiply to show alfa
Go to the Mapping group and set Coordinates to UV

In 3D view press Nkey and open Display tab and check Textured Solid (Makes textures visible)

Then in bottom of UV Image Editor click on image and select the cubes texture.
The image will appear on the screen
Align the squares over the image the same way you would move an object in the 3D view (You can overlap)

The image should be visible in 3D view so you can easily align them
If not press F12(PC) to render an image.

There are other ways that you can learn, but that should work fine.

Feel free to ask more questions on the forum, there are many people happy to help out :yes:

It really annoys me when people don’t come back to say thanks.