Transparent Background settings

I am trying to render my foreground, middle ground, and background in separate image sequences because I want to composite in another program that I am more comfortable in. I set film and alpha to transparent saved as a .png but its still coming out black. Did I miss a setting somewhere?


under the scene tab, uncheck the “Use Environment” box. You environment is probably set to black.

i unchecked it but its still rendering black :frowning: here’s screenshots of my other settings




I missed this in the first pic. Under render settings, click the RGBA not RGB. A is for Alpha.

Yup, without RGBA, there is no Alpha channel.

(Inquiring minds sometimes wonder … why do we even have that choice? And if so, why isn’t RGBA the default? Isn’t that, like, “just gettin’ in the way?” :rolleyes:

AH! It worked! I knew it had to be some simple setting change. It’s these little settings that always get me.

Here is a followup question. Now that I am able to render my foreground objects on a transparent bg, how do I render them with their shadows?

I saw this tutorial about doing a shadow pass http://www.blendertutor.com/shadow-pass-in-cycles/ but what I want to do is render the foreground with the shadows, not the shadows on the background. It’s an animation so in case I have to update the animation, I don’t want to have to re-render the background at all to save time, but if the shadow is on the BG I will have to.

Dont quote me, but i think if you keep the object to receive shadows on the same layer, you can just enable ‘shadow only’ in the materials tab under shadow. You would need 2 surfaces though. The real on it’s own layer like you wanted, plus a duplicate version on the foreground layer to receive the shadows.

Edit - Just realised you’re using Cycles, scrap that idea, sorry:p

When using a PNG format you’ll want to render out with 16bit RGBA. In Photoshop you can access your Alpha channel through the Layer panel under the Channels tab.

I suggest you render with OpenEXR or HDR format for both stills and animation, Stay away from PNG and JPEGs.
Photoshop will remove the black background for you automatically with OpenEXR!


Thanks! I’ll experiment with the OpenEXR. I’ve never used it before.

Also, I figured out the way to do the foreground with shadows through nodes after messing around with the nodes and watching these videos:
http://www.blendertutor.com/shadow-pass-in-cycles/

For any other noobs like me who run into this issue.