transparent faces showing colour

i dont know how to get rid of this, its plaqued me for years. I have a hair model, and i used textures to make the ends transparent to make it appear more hairlike. the problem is that in the parts which should be completely alpha-0, its giving me a dark colour as if its not fully transparent or a little colour is showing through.

here is an image of a recent render (see my pseudo realistic thread for more examples of it), which shows this problem.

look at the end of the hair, you see the curve below it where the mesh physically goes down to but is meant to be transparent. it can be seen very clearly over the iris.

Any ideas guys? this really has been getting to me for years and i could never figure out why.

Do you have Specular Transparency turned down to 0?

hey harky,
i’ve never encountered a specular trans setting in the materials before (i just know of the one below the colours in the material tab and using textures to control alpha and stencil). Where is specular trans located? (i feel like such a newb now! LOL)

Premul is your enemy, me thinks. Enable in the texture settings.