Transparent material combined with hair make behind object transparent.

Hi, I creating a character with particles for hair and I have a problem with some transparency.
This is not a hair related issue, I duplicated the head faces to a new mesh to be sure all vertices where just influenced by the head bone and added the particles system to that mesh. Then to have the hair rendered without the mesh I applied a “invisible” material by setting the z-transparency alpha to 0.
And this is the result:

As you can see the material is effectively not visible as we see the eyes inside the head, but we are not supposed to see them because the character itself has its own head not transparent at all.
For me the hair is drawn setting a zdepth which make blender not rendering behind it and antialiasing adds an alpha to it which makeit transparent, but I don’t know why.

Thank for your help.

I attached a minimal sample file with the problem: test.blend (950 KB)

Well, judging from your sample that might not be true…

The head mesh has a texture with alpha influence applied to it. Unfortunately you did not pack the textures into your .blend file, so there’s no way of saying what that alpha actually turns invisible.

BTW, if you don’t want the mesh that grows the hair to be rendered, just disable “Emitter” in the Render section of the particle system settings.

Very strange, in fact your true there’s an alpha but this is not transparent where the hair is, I had tried disabling particle system and there’s no transparency. So you can try with any texture and see the issue. It’s very strange (bug?).
However removing the alpha option for the material solve my problem and as I added it trying textured hair, I can go like that, so thanks !

I’m not talking about the “cheveuxfille”, but the “fille” mesh.

The texture of the “tetefille” material seems to only cover the face area, but is transparent where the hair is. This is what turns your entire head transparent outside of the face. So, you have a transparent hair emitter and a transparent base head, which results in a “see through” head.

I understood you’re talking about “fille” mesh, the first thing I tried was to have only the “fille” mesh with semi-transparent faces to create hair, it’s why I activated z-transparency (and forgot to disabled it later). But the texture pixels are not transparent anywhere, it’s why I don’t know why blender doesn’t render them behind the hair.
But as I said removing z-transparency solved my issue.