Transparent object preventing highlights on objects beneath

I’m following the Pixar-style eye tutorial on the Noob to Pro wiki. It calls for an eye setup where an iris is positioned underneath a completely transparent cornea.

I’ve tried this before, and have always ended up discarding the cornea, because it somehow prevents the iris from catching the light - that is, with a cornea there, the iris is dull and unhighlighted, but with the cornea removed (and no other changes made) the iris is colourful and has a strong specular.

I’ve fiddled with the settings, especially the Ray Transp settings (mainly SpecTra) and the Ztransp button, and nothing seems to make a difference.

How can I get light going through the cornea and onto the iris?

The iris material - is it set for TraShadow? It had to be to accept the shadows of transparent objects… I remember having a similar problem before too.

That seems to have done the trick. Cheers, Craig.

Okay, I have something rather puzzling here;


Here are located two .blends, both done with 2.45 16 for linux.

The file called “crab machine.blend” contains the only decent looking Pixar-style eye I’ve ever made. (It’s sitting on top of the first box - iirc you’ll need to reposition the camera to get a close up.)

In “yorp.blend” I’ve systematically copied all the settings. I noticed TraShadow was switched off in the other file, so I switched it back off (when switched on, it didn’t seem to give the same results anyway.) I’m honestly not sure what I’ve missed.

Can anyone more au fait with the workings of blender tell me what’s going on? Why two seemingly identical sets of settings are giving such different results?

(An aside: In yorp.blend, you’ll notice I’m having trouble with pinching at the neck. What’s the standard fix for that?)

check the alpha value with transp panel you must put this value low

with z Tranps i think it is automaticclly done for you
can you put up a file so we can check it out
but it should work fine in any case
Salutations

There are two files linked in the post directly above this one.

Changing the alpha value doesn’t seem to have any effect whatsoever - it renders the same at 0.0 as it does at 1.0. Also, in the file where it works, the alpha is set to 1.0.

EDIT: I was referring to the A: value in the materials panel. There is no ‘alpha’ to change in the Mirror Transparency panel?

i copied the eye lens and did a test for transparecy and seems to work fine
see pic
but you should put some values in IOR a value of 1 is for water so a lens should be
1.25 or something else thatn 1

you also let the Gloss at 1 which is a little strong
may be check out the wiki page on glass and transparencies this should help you set up the object
as it should be

Salutations

RickyBlender: that pic doesn’t look right to me: the shadow cast is far too strong. The same thing’s happening with the eyes: the cornea is casting a strong shadow on the iris, making it look too dark.

Does that happen if you do the same setup within crab_machine.blend? (It doesn’t seem to for me.)

i do have a light near the camera so you can see a shdow because of this light

i’ll see if i can remiove this shadow
but i think this is other objecst on which you spec no shadow in shader panel

ok done test yap that’s it remove shadow on shader p[anel for othere objects and shadow wont be there
see pic

Salutations

I’m expecting that you can see a shadow - the thing was, that shadow was much stronger than it should be, for such a transparent material.

In comparison, I got the attached pic, even with TraShadow turned off.

EDIT: I see; but the thing confusing me was that in the file, crab_machine.blend, Shadow and all the other stuff was exactly as you found it, and it still didn’t cast a shadow.

Attachments


Okay, this pic is the same scene rendered from within the yorp.blend file. I can’t see any difference, can any of you? However, one file is producing perfect eyes while the other’s look terrible.

I’m totally perplexed by all of this.

Attachments


shadows are functin of the differents sources of light and their location
but this is taking care by the renderer automatically
but also it can be influenced by some of the setting like IOR specular values mirror values

i mean thre are so many variables that can influence shadows
not always easy to find which one is at fualt it depend what you want to do !
there are dozeb of pages on lighting and it’s effect including shadows
so it’s not an easy subject per say
hope it helps
Salutations

That’s exactly the problem: I have systematically ensured that, at least in the Materials and Render option panels, ALL THE SETTINGS ARE IDENTICAL.

Where would any other relevant settings be hidden?

what effect do you want to do ?
have just a little bit of shadow
try to put more lamps at different location this shold reduced the shadow effect on objects!

then may be i can try to help you more

but need to have moe details on what your searching for

Salutations

It’s alright. I still don’t understand what’s going on, but I went back and managed to get a satisfactory result using TraShadow and some nodal compositing. It’ll do.

Cheers for your help, though.