Transparent Part of Model Not-Being-Transparent

So, here’s my issue in words:

Let’s say I have a cube - a 0.8 x 0.8 x 0.8 cube. I have a applied a texture to it that covers up all parts of said cube.

Now, let’s say I have another cube. This one ix 0.9 x 0.9 x 0.9. It is placed so that the margin between the sides of the cube is exactly the same all around.

For this second cube I have another texture - this one does NOT cover the entire cube - it only covers some parts of it.

My goal is to have the second cube be mostly transparent (except for the textured parts), so that the inner cube is “caged in” by the outer one (or its texture, anyway).

I have fiddled with the materials a bit and I have it rendering - my only issue is that the outer cube renders as either black with the texture over it or (properly shaded) gray with the texture over it. I want to see the inside cube, but I can’t; it’s covered up by the black or gray.

Spoiler Alert: I’m trying to be able to animate Minecraft stuff, specifically, my character, and I want the “hat” layer to show up properly. If you’ve played MC, that will make more sense than it will otherwise. :wink:

Note: Due to being a blender noob, when I say “texture” I mean “image, certain parts of which I want to put on certain faces.” I do not know whether this is correct.

I will attach the .blend and the .png I’m using as a texture.
Type1NinjaModel.blend (579 KB)

Is this what you want ?

For Material.001 you need to:
Enable the Transparency option and set the Alpha slider to zero
For its texture you need to enable the Alpha influence option so the texture is now controlling the transparency

For the body material under its Shadow settings enable the ‘Receive Transparent’ so transparent textures don’t cast solid shadows


Type2NinjaModel.blend (588 KB)