Transparent .png only throws solid shadow


Can anyone see what is going on here? My transparent png file only throws a solid shadow in object mode. I’ve tried with a few different files, with the same result. When I hit Play it shows the spots, but the shadows jitter.
I’d appreciate any advice?

Here is the .blend file:
texturing tut2.blend (586 KB)

blenders opengl is too old.

try upbge to fix the jittering shadows.

Thanks for the response - could you explain this more? Is it a plugin that needs updating?

nope, its just old.

thats why all this EEVEE jibberish has got everyone so excited. its a great big update to opengl and the viewport.

I’m a bit confused. I’m following some tutorials and the author is using v2.74, and there are no problems in his or other people’s rendering. It’s not particularly complicated! It’s just a simple shadow.

There doesn’t appear to be a Mac version of UPBGE in any case.

Any further advice?

Variance shadow maps do not support alpha…this is a possible cause…make sure shadows are ‘simple’…and in viewport it is generally not supported…only when the game engine is running with simple shadows enabled, does it work…so it will not work either way in object mode.

the jitter is the shadow resolution. after you fix your settings.
the square result stays in 3d view, just check when running the game if shadows are what you want/need.

edit you have that lol, looked at your blend. select plane, hit material then texture tab, deselect use alpha, scroll down to the alpha slider put it on -1, it gives you better result, and that’s the way to use it in the engine.

dont think use alpha checkbox is meant for ingame (not sure)

Where do I change the shadow resolution?
I also tried unchecking alpha and that didn’t work.

I’m confused, as I’ve tried this with the exact setup from the tutorial, using the image files supplied in the tut, and no-one else has complained of the same issue.

I have had this jittering issue when playing even a really simple game file, maybe it’s not to do with the shadows?
If I play from camera view, everything outside the view jitters. If I play from another view, sometimes the start button in the properties panel jitters. Sometimes the whole panel jitters. I can’t seem to reproduce a consistent result.
Here’s a screengrab.

try blender 2.74, it doesnt have the shadow jittering issue, or rarely atleast. what your seeing could be related.

for me it works in 2.74. but only in the game mode, which is due to old opengl in the viewport. checking transparency in object properties makes no difference. you need to have transparency checked in the material though.

Here’s a screengrab.

hmm, looks like a graphic (card) driver issue to me.

Where do I change the shadow resolution?

in the lamp settings. but in this case i don’t think that it is the shadows who causing that.

No, no difference in 2.74 :frowning:

As I recall, you need to use simple shadows and have clip alpha enabled in the material for transparent textures to cast shadows correctly in the vanilla BGE.

Thanks for your input. Could you point me to a reference or explain how to enable “simple shadows”? is this a global setting or related to the object casting the shadows?
And where is “clip alpha” enabled? There seem to be so many places to check “alpha”, I’m confused.

I’ve opened a new thread for the jittering issue, as it seems to be independent of the shadow problem. Sorry for any confusion.

OK, I found it - it’s the lamp, not the object.

If you are interested, you could try to compile Upbge on mac?

I am interested - I went to look for an installer and gave up when I didn’t find one. Can you point me to step by step instructions on how to compile it? I’m not used to doing this.

Apologies, I should’ve been clearer.

You found Simple Shadows - it’s on the lamp, in the shadow section.

As for Alpha Clip, with “Blender Game” activated as the render engine (which is the drop-down at the top of the screen, on the info panel - the panel where you have the “file” menu), Alpha Clip can be found in the material itself, in the Game Settings section. It’s the alpha blend setting, which is set to “Opaque” by default.

Thanks - I’ll try this combo - so far no change!

Sure. Here are instructions -

  • First download the XCode and Cmake, then download the svn libs( link: ) For the svn you could use a gui svn program instead of a console if you want. Now make a dir: Bdev/lib/ and bdev/build-upbge/
    The svn libs should go to the lib dir.
  • after installing the soft go to the git console and do the commands to download the upbge. So its cd bdev and then git clone After that the files should be downloading and youll have a blender dir in bdev/
  • So now that you have all done its time to use cmake to generate the build files and then use xcode to compile. Thats usually how i do it in windows. :slight_smile: