Transparent/reflective window


At the moment I’m starting to learn the BGE and I have some issues trying to create a window which is transparent (shadows are effected by transparancy) and reflective.

At this point I have a plane which is transparent but the shadows stay black.

I googled a lot and I saw some create posts here about reflective/refractive glass with all kinds af scripts but this is too advanced for me. Don’t even know how to copy those settings in my scene to get the same result.

Can someone point me in the right direction?


receive transparent on the stuff around it, in shadows in materials,

You can disable shadows for the glass material. This way it looks much better.

To get rid of those shadows, go to the windows material settings and look at the “Shadow” section uncheck everything.
As for the reflections, in-game reflections are not possible using basic material settings. Scripts are essential. However, the effect can be mimicked/faked (not even a good alternative, but without scripts, one of the only ways) using the “Reflection” UV map.

Thank you for the replies. Is it possible to get realtime semi transparent shadows? Or are the only options black or no shadows at all.

I’ll probably have to learn some scripting. There are probably some scripts out there. Any tips?

I tried to cast some shadows in glsl mode with an alpha map. In the render I get transparent shadows but in glsl mode not. I attached a render/screenshot and the blend file. How do I get transparent shadows in glsl mode (game engine)? I checked recieve transparent shadows for the ground plane but this doesn’t seem to work.

test shadow alpha.blend (628 KB)

Better do not refer to render. The BGE has nothing to do with Blender rendering. It is a different application = producing different results.

You’re right. But does this mean that in BGE it’s not possible to have transparent shadows?

Know it is not possible in multitexture mode (in that mode there are no real-time shadows at all).

I know it was discussed in the past, but I did not followed that. So I can’t give you a clear answer on this.

There is an option in the shadow panel of materials tab that says ‘receive transparent’ this will allow that material to receive transparent shadows.

That option is only for renders, it not works in the bge.

Realtime alpha shadows not work in the preview, try open the game pressing “P” or use the standalone player and make sure these options are enable in all materials:

Ok, your file not work because you are using variance shadows, only simple shadows have support for alpha shadows.

I checked the receive transparent box in the material and started the game with p. Still doesn’t work. I’m using glsl shading. Maybe someone can check my blendfile I attached early on? Don’t know what I’m missing.

Maybe it’s what Monster said and it’s not possible at all.:frowning:

Look at my last post, variance shadows don’t support alpha shadows.
test shadow alpha.blend (568 KB)

Wow, thank you so much. It works. Everybody thanks for the replies. Great community.

in some cases can be useful do the opaque part by poligons then assign two materials and for the transparent one with the settings of the picture. This way you can use variance (soft) shadows which look very nice.

Note the transparency and Invisible properties (in a red box in the picture) for the transparent mesh.

test shadow alpha_2.blend (620 KB)

Thanks for the tip. I think with windows this is a good option.