Transparent Shadow issues in Blender 2.5

I have gone through every forum and tutorial that I could find to help me try to get the transparent reflections working right, but seem to have something missing.

I found the information about transmissivity at (, but it describes it for the older blender versions (I’ve applied the settings that I think are the 2.5 ones with the new names, but I could be wrong there too).

My render ends up looking more like the “fake” shadows that the new abilities are supposed to get rid of. I have attached a visual of what my render looks like (notice that all of the shadows are just black, and the same shade). Other than that the objects look pretty much like the one at the link above. If I try to turn on “Receive Transparent” on the plane, then it doesn’t get ANY shadows at all. I’ve tried just about everything that I could think of, changed just about every option, changed lights, etc. I’m sure it’s something easy, y’all are pretty good at figuring this stuff out, so I know you’ll find it!

I have also attached the blend file so that everyone can see what my settings and try to rend it yourselves.

I’m using Blender Alpha 2 2.52.5 r30209 (I have also tried the r30180 and r30192 versions).

Thanks in advance.



Transmissivity Test.blend (93.7 KB)

Wrong post


I’m not exactly sure what you’re after, but the reason your shadows are not appearing when you select Receive Transparent on the plane is that your objects have an alpha of 0 - they are completely transparent and therefore don’t cast shadows. Try increasing the alpha.

Ah, that makes sense.

Got things to work, that was the issue. I had followed so many tutorials on making “glass” stuff that all said to set the alpha to zero that I figured that couldn’t be it.

The render below was done with an alpha of .250. The glass is a little darker than I really want, but I can play around with that.

Thanks again for the help. You rock!