Transparent Textures and All Z

Hi,

I’m having a problem compositing an image plane with a transparent texture into a scene. Hopefully these images will demonstrate what I mean.

The pilot render layer has All Z checked but Blender seems to be masking out a little too much of the pilot around his ankles. A Z-combine node produces the same missing section around the ankles.

I have tried separating the plane’s parts onto their own render layers but this is an animation so sometimes the wings cover the pilot and sometimes the pilot covers the wings.




Hopefully someone can knows what I’m doing wrong, been pulling my mohawk out.

Kerry

Try using the Save Buffers option along with Full Sample Anti-Aliasing. In this way you’ll get the depth (Z) channel to anti-alias rather than cutting out jaggy pixel blocks.