Transparent textures not transparent?

Hi, this is my first time here so please correct me if I’m in the wrong place for this…

I am going through the ‘noob to pro’ semi-instruction manual and have reached ‘pixar-eyes’. This is my first bout of transparent materials, and I have a problem.

The attached file shows my ‘eye’ with the lens (cornea?) translated along one axis. It shows as transparent while the world is behind it, but not when the eye is behind it, it becomes black. Am I doing something obviously wrong? Any help would be greatly appreciated.

Attachments


You need to turn on Trans Shadows for the Iris and the eyeball. Otherwise, the lamp uses the transparent cornea as a solid mesh and thus, casts shadows on anything behind it.

Hope that helps.

BgDM

Thankyou! That worked perfectly :smiley: