Tree makeing

how do you make a plane transparent, but the image opeque?
This like shows you what I am talking about http://www.worldforge.org/media/documents/docs3d/tutorials/vegetation
Its the very first tree you see on that page.:rolleyes:

please help!:confused:

ok, i don’t know if you already have an alpha texture ( texture with transparent regions ) to work with, so to start from the beginning…

  1. if you don’t have an alpha texture already, we’ll make one. use the treegen plugin to make a tree, or you can use any object that’s handy. put the object in front of the camera, and set up the lighting.
  2. now, in render buttons, change the format from jpg ( default ) to png, click on the button that says RGBA ( red blue green alpha ), and also the button that says ‘premul’ ( premultiplied alpha ). or, if you want hard edges instead of soft edges, click instead on ‘key’.
  3. now render your object. the picture you rendered will be your alpha texture. everything that was background has been rendered as transparent.
  4. now add a plane, and put a material on it. go to textures, and add a texture channel of type ‘image’, and load the pic you just rendered.
  5. still in texture buttons, click on the button that says ‘use alpha’.
  6. go back to material buttons, and in the ‘map to’ buttons, click the button that says ‘alpha’.
  7. now, over on the left, click ‘shadeless’, and turn the alpha slider all the way down.

that should do it.

i’d leave ‘shadeless’ as it is. renders better without it.

but what about shadows? blender keeps renderig this treeimage with planes shadow (same plane where the treeimage lays) and i can’t find a way to correct this.

but what about shadows? blender keeps renderig this treeimage with planes shadow

On the object recieving shadows, turn on “TraShadow” on the shaders tab in the material buttons window. Check out my thread on this subject - I created a huge forest with alpha-mapped trees:

http://blenderartists.org/forum/showthread.php?t=75075

well… [trashadow] is on

i just upgraded to 2.42a, maybe it has something to do with this. i have turned on and off everything i could for hours. raytransp and z-transp, shadows and rays in rendering options and shadeing options. traceable and shadbuf in rendering pipeline etc. …nothing. there’s only two options. i don’t have any shadow at all or i do have planes shadow. finally i just appended a tree from known 2dtree tutorial file and guess what… …it has the planes shadow. fcuk me and me mother and all the tiny animals around. this is freaking me out.

guess i have to downgrade to 2.41 and see if this is the case…

btw. new lsystem script is just beautiful and i love the guy who wrote it :*, but if you need to create a huge landscape you can’t use too much of those trees or you’ll die before you see the rendered pic.

i just upgraded to 2.42a, maybe it has something to do with this. i have turned on and off everything i could for hours. raytransp and z-transp, shadows

Did you try my blend file? It alpha trees cast perfect shadows in 2.42a - I just tried it. Check out my settings on the alpha trees and the ground plane.

link to blender file:
http://markopuff.com/animations/poplar_mist.zip

Heh. I don’t know what i did yesterday. Today everything works.
But now i have totally different problem. I can’t track those trees to empty correctly. After tracking the treeplanes will lay down and i can’t make them face up again. in constraints buttons when i change Up: from [Z] to [Y] the plane will stop following the empty… So how can i track them right?

No worries… tree is up and working