Tree of death (or: how a simple .blend model suddenly starts eating all RAM)


I have a reasonably simple .blend here with a single tree, a ground plane and a HDR image for backdrop/lighting, plus a single emitter plane for some sunlight.

Here is a link to the .blend file.

This is what it looks like with a quick 10 sample preview, to give you an idea:

This means of course, that a rendered preview is no problem, and it renders in a couple of seconds with Cuda. There is no scene compositing at all, so I figured a normal F12-render of the scene should be pretty much identical to the preview.

I’ve used hair particles to add the branches, but they have all been applied, so the only physics systems is the one distributing the leaves (two types, grouped). Hair system, distributing according to weight paint on the tree mesh.

I’ve baked the textures into the blend file for this post, normally they are in the Textures subdirectory.

This all used to render perfectly, but something has happened that makes it go all haywire. Whenever I try to render this now (tried on two different Windows and one Linux system, Cuda and CPU, latest nightly build and stock 2.63), Blender starts eating all my RAM (16GM on my main system) and then all the swap and after that my system, no matter which I use, is a smoldering hole in the ground - had to hard reset my windows box).

The only clue I have is that it happened about the time when I added bump maps to the two leaves that the physics systems uses. But in the attached blend, I have disabled the bump mapping, and I still get the same effect.

Does anyone have any clue as to what on earth makes this relatively simply model sink Blender? (Again, Linux/windows/nightly build/stock build/cpu/gpu makes no difference). I don’t understand why Blender should require several tens of GB of RAM to render this model, particularly when the preview is a snap…

oh, and just so nobody gets very upset with me after trying the .blend:
WARNING: running this blend might sink your system. Please save all data before trying.

PS: I’ve played a lot with the render setting to no avail. I’ve used tiles in the latest build to try to pull down the RAM requirements, but I don’t think that this is it, considering that is happily renders the preview… My guess is that something with he physics is doing this.

It is “Subsurf of dead”, you have subsurf 4 on render, reduce it to 1-2.
I think preview “simplyfies” for faster work.

Gruss, mib.

YES! It solved the problem! Thanks a bunch!!! :slight_smile: