Tree trunk / branches / leaves movement and scaling (all as one)


Apologies if I’ve posted this to the wrong part of the forum. ‘Basics & Interface’ just seemed to me to be the most appropriate section.

I’ve created (using the Sapling add-on) a sycamore tree. …My very first attempts using the sapling add-on. Please see the attached image.

The trunk, branches and leaves are all now mesh Objects, following conversion from curve.

Regarding my attempts to move them :
I now wish to move the trunk, branches and leaves (all together) in 3D space, to place them in my scene. I seem to be able to move the trunk and branches, but the leaves don’t stay with them. (The leaves either don’t move at all, or - if they do initially move - they jump back to their original position after a few seconds). I seem to remember something about having to ‘clear parent’ on the leaves ? So I tried that (selected the leaves > Object > Parent > Clear parent), but it doesn’t seem to work. Could anyone advise me on this, please ?

Regarding attempts to scale the trunk, branches and leaves all together :
In the same way that the leaves don’t seem to want to move (above), they also don’t seem to scale. Is it achieveable, after I’ve reached this late stage in the development of the tree.

I don’t know whether or not this is directly relevent to the above problems, but for your information : I used a cloth simulation (over just 26 frames) to create some drooping in the leaves.

Can anyone help me move / scale my tree, branches and leaves all as one ?
Thank you!


Would love to advise but IDK how you have your scene & mesh organized. Just share a file if possible.

Unfortunately, the file’s a long way above the maximum limit for uploading a .blend file

MMM, I seem now to have a tree that I can move and scale, though I’m not sure I fully understand how I achived it. In the end, a simple Shift-D and move then re-scale on the duplicate Objects worked…But it didn’t seem to in my previous attempts.

Anyway, off the back of that, I have another issue that I feel I should know how to quickly resolve, but it’s not coming to me. When I render the tree with a fence in the background, I’m getting the leaf borders show in the render. (Please see the attached image). I’m using Cycles. The tree and the fence are on separate render layers, and on each render layer I’ve Masked all other render layers. In Render settings, ‘Output’ section, I’ve selected RGBA, and in the ‘Film’ section, I’ve ticked ‘Transparent’. What needs to be tweaked to get me the desired result, please ? It must be staring me in the face…

Edit : Not sure the image is sufficient to show the problem. What I mean is, the checkerboard pattern is showing in the render, between the edge of each leaf and the edge of the square that it’s mapped to.