Trouble (Bug?) with Particles and Animated Texture

Hi,

I don"t know where to submit this post. As it is related to a problem using animated texture, I hope that it is the good place…

Here is the problem :

I’m still working on my Tracks Creator,and including it in my 4x4 Autodrive system.

I have encountered a very annoying trouble while using an animated texture (sequence of images) to animate wheels tracks in grass.

For Blender users who have read my tutorial about the Tracks Creator, I said that I used fields instead of Texture settings in the Map To panel, because I had difficulties with it. This time, I decided to dig more in depth with this panel, and what I have found seems to be a bug.

Here is the panel I used :

http://3d-synthesis.com/Bugs/Particles&Texture.jpg

It works fine on a still picture, and I have got the expected result :

http://3d-synthesis.com/Bugs/Grass-Crushed.jpg

It is what I wanted : The grass is like crushed in the sand and not visible in the tracks.

The tracks in the sand are made thanks to a displace modifier (the ground is subdivided enough) and also have the details enhanced by both a Color and a Nor parameter. The tracks in grass are done with the Particles settings of the Map To panel applied on the grass material. The area where there is grass is defined by a vertex group declared in the particle system.

Everything is fine on a still picture, but the problem is that it doesn’t work in an animation !

It appears that the new frame of the animated texture is loaded only each time you enter and exit of the Edit mode ! In the ordinary process of the animation or the rendering, the texture sequence frames are refreshed for the displacement modifier, but are not for the Map To parameters of the texture.

Here is what I get in an animation :

http://3d-synthesis.com/Bugs/Grass-Folded.jpg

The grass is moved, because it grows onto a ground mesh which is deformed by the Displacement Modifier, but the grass particles (velocity and density) are not affected by the material Map To texture settings… until I select the ground mesh and Enter/Exit Edit mode.

As I started the project on Blender v2.48a, I have done a trial with v2.49a to see if there was a difference. There is one difference, but not the expected one. The trouble in animation is the same, but the image when rendering a still picture looks different, with exactly the same settings that I used for the first image :http://3d-synthesis.com/Bugs/Grass-Crushed_v249a.jpgbit
After making a simplified scene with similar settings, I have discovered that in Blender v2.49a, the button Dens (for Density) of the Particles settings in the Map To Panel has no effect ! So, in this third image only the IVel (Initial Velocity) Button has an effect on the particles. In the first image, instead, both Dens and IVel buttons are active, and there is no grass at all in the tracks. Even if the third image is more realistic, the behaviour of the Dens button is not the expected one !

What is your opinion about that ?

Currently, this trouble ruins a part of my efforts on the Tracks Creator, because I have to switch back to the field method which is less accurate and harder to setup.

My most recent test with the Tracks Creator and my 4x4 Autodrive system (still no good sequence with grass, due to the explained trouble :

http://3d-synthesis.com/VideoTests/Blend-Rover_11.mpg

The same on vimeo :

http://blenderartists.org/forum/showthread.php?t=162475

Below, I put two links : The simplified Blend file and a Zip file containing a sequence of 100 jpg images (Animated tracks) to be used with the blend file, for the Ground Displacement texture and the Grass particles Density.

http://3d-synthesis.com/Bugs/Tracks-Test.blend

http://3d-synthesis.com/Bugs/Tracks.zip

Thanks in advance for any idea.

Edit : Well, as I got no response, I have submitted a report to the Bugtracker.

Well, no response so far, and I got no response as well from the Bugtracker…

Maybe because it’s vacation time ?

This trouble is very annoying, and at one moment you may fall on it.

Please check my blend file !

Thanks in advance.

I ran into animated texture refresh issues when I was writing Blendgraph. What I discovered is that, indeed there is a bug in the Blender refresh system. I think it was acknowledged and part of the 2.5 re-write is handling that bug.

My work around, and this may sound silly was to apply the animated texture to a plane, put it behind the camera and leave the plane selected. This was the only way the auto refresh would work. I had to have the texture panel open in the GUI and the plane selected as well. Then the refresh worked.

Sorry I don’t have more to offer, I know it sucks to come so far only to be stopped by the system.

Can only confirm this bug/unwanted feature. I just wasted a couple of hours trying to figure out why my dens map wasn’t being updated correctly until i found this thread…

Thanks a lot for this confirmation !

@Atom, thanks, I will try your trick as soon as possible ! I hope that It will help me to continue !

I will tell you if it works.

Edit : Tested… it doesn’t work :o((

The texture itself is refreshed, but the information is not given to the particle system which is not refreshed…

I hope that I will have a response from the Bugtracker… a v2.49b would be highly appreciated !

Still got no response from the Bugtracker. I don’t know if the Bugtracker is only active during Release Candidate periods, or if the developpement of Blender 2.5 has put 2.49 in a shadow area, but if they are not taken in account, these very annoying troubles could be transferred in 2.5, and not solved before 2.5a ! :frowning:

Reported as Bug # 19037.

@ROUBLAL:

Your right, it does not work at all in 2.49, but it does still work in 2.48 (the density).

What I did is wrote a script and placed it in the frame change event of Blender 2.48. All the script does is take the selected object and put it in and out of edit mode. This actually worked, I could see the tracks moving through the particles.

So if you are willing to downgrade to 2.48 and try out the script, it may be a solution for you until the real bug is addressed.


import Blender
from Blender import Window,Scene

print "->Frame Change"
scn = Scene.GetCurrent() 
obj= scn.getActiveObject()
Window.EditMode(0) 
Window.EditMode(1)
Window.EditMode(0) 

Place this code in a text window and assign it to a frame changed event in Blender 2.48.

Atom, You are my Hero !!! :smiley:

It works ! I have just tested it in Blender 2.48.

Thank you very much ! As I’m completely hopeless with Python, I wouldn’t have been able to write a single line.

While waiting for a bug fix release, your script will allow me to continue my project.

In my current scene, the Density button not working is not really a problem, because modifying the density means that grass blades that are substracted in the tires tracks area are added in the other part of the terrain. This cause the grass to appear moving.
So, I will only use the Initial Velocity button. So I can use v2.49a !

Yepee !

Thanks again ! :yes:

Philippe.