Trouble creating a ceiling on Darins tutorial of a Mac

I am using blender 2.79 and I am in Cycles Render. My problem is regarding the construction of a ceiling where it more or less divides into two planes when I extrude it from a mesh plane.

  1. My walls have become temporally see through when I move around the scene.

  2. The plane for the ceiling is also ‘half’ see through, (is transparant on the one side). When I extrude it becomes two planes … so I have no edges on the hole in the ceiling which I need for this project.

  3. There is a red line around the view port.

So far I have tried deleting the top part of the 'double ceiling and extruding the bottom part again without any luck. I have tried recreating the ceiling in a new scene and pasting it over without any luck. I have tried pressing F and using the solidify modifier also with no effect. It isn’t back face culling either. Also I tried clipping after a suggestion but it wasn’t that either.

All help and advice will be very much appreciated.

Thank you.

Erm… What?
Without linking to the tutorial you supposedly followed or showing screenshots and/or a .blend file, your post is almost completely incomprehensible, I’m afraid.

Who on earth is “Darin”? Or do you mean Darrin Lile? If it is, please say so and give a link for crying out loud. And don’t forget to mention which of his tutorials!

Hi IkariSginji, thank you for answering. Yes it is darrin Lile. I would love to include screen shots but that option doesn’t seem to be available to me. Possibly because I am a newbie here. The tutorial is on Udemy so probably not available if you are not paid up to it. Here is a link to the page where he has his course and it is called ‘Learn Animation Production with Blender’. https://www.udemy.com/blender-scene-creation/ Unfortunately the file is too large to upload, (and I have no idea how to upload to the cloud sharing place), but here is a file of the ceiling alone which may help to clarify the problem for you. Also I am sorry I didn’t see the option to add a file the first time around.ceiling extra.blend (822.4 KB)

Hi IkariSginji and folks … I found an old copy of this, (which I had cocked up but in a different way), and the ceiling was ok so I have copied and pasted it over. It looks like it should be ok now.
Thanks.

Sounds like you have set the option to make faces invisible when viewed from behind (Cull Backfaces).
With your ceiling, if you have extruded from a flat plane, it’s possible the outward face (face normal - the direction it’s facing, ) is now facing inside the box you have extruded, and the sides are also inside-out. With backface culling on they will look invisible. Try selecting all the ceiling in edit mode and recalculate Normals (face directions ) with ctrl+n.

1 Like

In your file - switch to Front Ortho view and switch on face normals for Mesh Display


Now, if you W -> Remove doubles and recalculate normals you’ll see blue lines pointing one way only. Select top faces and flip normals if needed.

1 Like

Sorry for the late reply. Thank yo so much for taking the time to help me.

So sorry about the late reply. Thank you so much for taking the time to help me.