Trouble Rendering Hair

I have a human head symmetrical about the x axis I have populated with particle hair. Everything looks fine in 3D viewer. But when I blender render after combing, the right side is fine but the left side is all helter skelter and is little effected by adjustments made in particle mode. Everything looks and functions well in particle mode. That is combing and styling.

What could be a cause of this?


Moved from “General Forums > Blender and CG Discussions” to “Support > Particles and Physics Simulations”

Most likely culprit is that you have a subsurf modifier on the head and that preview is at 1 and render is at 2. Change render to 1.

Hmm, now that I think about it are you using a mirror modifer? If you are (I wouldn’t recommend it for head har) you could experiment with changing the stack order. In modifiers there are arrows on each one, try moving the particle system above and then below the mirror modifer. Again make sure subsurf preview and render both 1.

Or, better yet., just apply the mirror modifier, recomb the hair and it should work.

If it’s not that post the blend, if it’s small just post the blend like an image, if it’s large use pastorg all.or dropbox and post the link.

Hey bad

Thanks loads, you’re a genius! Now the hair is silky smooth and managable. Your right, it is rigged character and there was an armature modifier attached (see screen shot). I don’t know if this is right but I made changed render subdivisions form 1 to 0. However, now I have another problem. The hair is perfect except she now is a good candidate for Rogein, completely bald on top (see attached image). My vertex covers the top of the head so do you know what can cause this?


Here’s what I would do.

  1. Set subsurf to preview 1 and render1. And basically never touch it again.
  2. On the hair system, click ‘free edit’ to undo any combing. Make sure your segments are at least 5. 6 or 7 is better for very long hair.
  3. Go into particle mode to start combing. There is a parameter called ‘Deflect emitter’, make sure it’s checked. Go to left or right view and comb the hair backwards from forehead to back of head. Watch how high the roots of the hair are pushed off the scalp. Now increase the value for deflect emitter, jack it up to .8, 1.5 or 2. Comb again, and you’ll see the hairs forced much farther out from the scalp. It kind of depends on the scale of your model but find a deflect emitter value that feels right. When you start combing the lower hair, by the shoulders turn the deflect emitter way down.

All worked like a charm! The settings and controls are complex and the particle editor is a bit funky first time around, but once I got the hang of it, it works pretty good. Cindy Crawford hair. Thanks again.