Trouble with export script


(Vidigiani) #1

Hey guys,

I am using the povexport.py script created by Jan Walter. When I try to run it I get the following error:

PYTHON SCRIPT ERROR:
Traceback (most recent call last):
File “povexport.py”, line 364, in ?
AttributeError: getCurrentScene

The line where the error occurs is, of course, Blender.getCurrentScene(). I downloaded the latest Python release for Windows and I have Blender 2.23 installed. Anyone else run into this or know how to solve it?

Thanks!


(Vidigiani) #2

Ok, in a similar post Schlops and acosto (sp?) indicate the API has changed at some point (presumably at v2?). Anyway, this line fixed the problem:

import Blender210 as Blender

You use this as a replacement for the line

import Blender

Anyway, thanks to Schlops and acosto who solved my problem without realizing it! :stuck_out_tongue:


(blender_man) #3

Hey,
I was having the same problem and it worked but after running the edited script i tried to render a model in pov ray but it didn’t work. :frowning:

-Error- Cannot open included file trimap.mrc Chenck that file is in a directory

Whadda i do??? :o

Any help would be appreciated


(Vidigiani) #4

Oh, well, it turns out that script doesn’t export anything but meshes… so if all you have is meshes I guess its cool… Didn’t work well with my scene.

Anyway, if you want to render your new .pov file in pov ray you need to download the trimap.mrc file. Its at:

http://www.janw.gothere.uk.com/Download/Python/trimap.zip

I was looking all over for that file too at first :slight_smile:


(jms) #5

Why don’t you try this povray/megapov exporter?
http://jmsoler.free.fr/util/blenderfile/povanim.htm

@+


(Vidigiani) #6

I will give it a look-see when I get home tonight. Thanks for the link jms!


(azrael) #7

“Oh this is the latest version, therfore it must be the best”

This is a common problem that people run into. Athough it may be the best, blender is compatable with python 2.0.1 so this is the version that you should download. It is avalable at

http://www.python.org/2.0.1/#locations

Hope this fixes your problem

Geoffrey 8)


(jms) #8

All scripts (except one or two, oldest, but they don’t work even with python1.52) work fine with python2.2 on my windows98 system, and also on my mdk8.2 Linux one. The most common problem is the correct installation of python ( no PYTHONPATH in autoexec.bat or bad directory name with space, “mydisk:/Programs Files/python2.x”, for instance).

jm