Trouble with my Linux Login - Debian/Gnome

I have two hard drives and was originally set up with Fedora Core, well originally RedHat 7. Anyway, my old linux guru couldn’t get Fedora Core to recognize my external hard drive, then was too busy wiht a new job to help. My new guru installed Debian on my other hard drive. I could then get to my external hard drive, and access the files on the other hard drive from my RedHat/Fedora days. After finishing 8 jobs for a client, and having started the next on spec, I can no longer get to my Debian. The login won’t complete. I get a long winded message about “something bad happening . . . will try again in 2 minutes. . .” This was the actual error message. Fortunately, unfortunately, my client decided to just use a series of photos instead of my ‘virtual time lapse’ version done on Blender. Fortunately, since I no longer had access to the photos emailed to me, which were on the Debian drive.
To get my Blend fix for the day, I installed 2.41 on the Fedora side. Waiting for my guru to get over a cold or . . . one of you folks to the rescue?

eehm… what?

your explanation is quite… unclear! From what I can see " something bad happened…" sounds as if you have some problems with your X-system, correct? you could post your error message contained in /var/log/Xorg.0.log or /var/log/XF86.0.log - but only the LAST 30 lines please! Maybe this can clear up things…

btw what kind of linux guru do you have that is not able to get a external hd working with RH?? ts ts ts…

I believe you’re right about it being an X-system problem. I’ll try the forum you mentioned, though my latest guru tried one and got reports that other folks had had similar problems and their only solution was to wait 30 minutes and let the computer continually retry until it opened. This didn’t work for me. I left my machine alone to retry for several hours without any result.
Both my gurus are more network guys and don’t do graphics at all. My first guy just plain ran out of time.
Thanks for your input krizu,


‘something bad happening’ is nothing to go on.

Are you saying you can’t logon to get a Gnome or KDE or other session going?

Assuming it’s a X problem then:

Are you using Nvidia or Ati Vidcard? If your using Nvidia and can get a commandline logon then you could edit your /etc/X11/xorg.conf file and swap nvidia for nv. I regularly have problems with upgrades to the Nvidia proprietary drivers screwing up X. Just to get you a session going to fix your problem if your more a gui person. If your with ati or other sorry can’t help.

Have you tried using a Live Distro CD to get you a Gnome or KDE session going so you can assess your drives? Regradless of distro you had drives setup with the important bit is whether there ext2, ext3, reiserfs etc all of which any Live distro will almost certainly let you access.

Otherwise perhaps a bit more info might help


I didn’t mention any forum!? there’s one file under the directory /var/log called Xorg.0.log or XF86.0.log (depending on if you’re using XFree86 or containing error/success information about your last startup of the X-window-system. I ran into similar problems when I upgraded my debian to so I could be of help, maybe.