Trouble with some matierals appearing transparent in my .exe (2.57) but not BGE

Hey everyone. I’m working on an enviromnent that my work would like to use to demo our equipment. Everything is going well except 1 thing. When in blender, If I start the game engine everything appears as it should, but when I export the runtime and open the exe, several materials and objects are transparent when I don’t want them to be. The object is still present (I can collide with them), but they are invisible. I’ve checked everything I can think of in the material settings, but there doesnt appear to be any difference between the materials that show, and those that dont.

Most of the objects that are transparent have mulitple materials. Could this be the issue?

Another question. Has anyone tried to use the video texture in an exe? The video plays in the BGE, but I haven’t had the chance to test it in the exe since I can’t see the object.

Any suggestions/help would be appreciated.

Are you sure that your textures are in the correct place? In the File menu, there should be something like “External Data”. Select that, pack the data into the blend file, and then export the runtime. Alternatively, place the textures relative to where they are in the project folder.

As to your second question, the bge.texture module (VideoTexture for 2.5) works in standalone executable form, so VideoTexture should, too.

What kind of modifiers are you using?

hmm, I’ve tried packed and unpacked textures. the same materials are missing. I have a set of seats taht I’m using an array modifier and a curve modifier. 1 material on that object shows fine, and the other is transparent. I have a scoreboard with no modifiers, and the whole thing is invisible. Could it be a bug with 2.57b runtime exporter?

After some testing, I found that the 64bit 2.57b exporter fails miserably. 90% of the objects are invisible and all the textures are screwy.

The 32bit works better, but still has transparent materials.

There are odd bugs with modifiers and the Blenderplayer. Here is a bit of a test:

  • Backup your blendfile
  • Apply all modifiers in your scene (except armature modifiers)
  • Export a new runtime based off of this blend

Does this solve the problem?

I’ll give it a shot.

I suffer the same pain for the same trouble.
Did you solved the problem?

A lot of these types of issues have been fixed in Cucumber, so you might want to try and use a Cucumber build:

EDIT: Looks like Moguri beat me to the punch. That’s what I get for not refreshing the page before posting xD

You can try a build of the Cucumber branch. There is a bug in Trunk that causes some problems for rendering in the Blender Player (mostly with modifiers). This bug has been addressed in the Cucumber branch.

If you are on Windows you can use this build:
If you are not on Windows, let me know what OS you use and I will try to get a built up for you.