Trouble with Tribbles

Well, ok… not tribbles, but it could be!

I’m trying to do a mesh-based static particle system (dupliverts) to replicate grass on a hill.

I’ve got the system set up, and I can see the particles (in white) on my mesh. It all looks good until I render… then… Nothing.

Is there something I need to do special to make the particle system render? I’ve used particles before (for the cigarette smoke in my “Checkmate” scene) and didn’t have these problems.

I’ve tried everything i can think of, including starting over with a fresh file… but still no rendered grass! :frowning: Please help?

if your particles are not staic, try moving forward a few frames.

Below the ‘Static’ button set ‘Life’ to give particles length.

Set ‘Norm’ and ‘Random’ to positive values.

Use ‘Vector’ for definition.

Use ‘Halo’ for texture.


OK… restating the problem: The particles are there in every respect except the render.

I’ve set the Normal, Life, etc, to exactly the way I want it.

The Particle system is static.

It is based on an existing object with duplivert on, and hence does not use a halo texture.

Please help?


I’ve tried everything i can think of

Same here! Except to ask ‘Do you have lights, camera, camera clipend, camera pointed at object?’ Not insulting you, just asking since you don’t say what you DO see in the render.


Sorry… yeah… I see everything BUT the particles :wink:

Didn’t mean to be snippy… just getting frustrated.

BTW… some more info:

I turned OFF duplverts and now can see the fuzzy, tube-worm particles, so maybe it has something to do with the mesh the particles are based on? Is there some requirement for Duplivert meshes that I need to know about?

Hm, Hm, think I still didn’t get it.

One interpretation:

You want the particles to be the grass and “dupliverted” the mesh, the particle system is based on, to another mesh, your landscape.

Then you shoudn’t see the particles of the dupliverted object in the 3D window, but in the rendered image. (Don’t ask me why)

To make the particles visible in 3D window make dupliverts real (Ctrl+Shift+A; “landscape mesh” selected)

Another interpretation:

You build up a static particle system from your landscape mesh and want to have each particle replaced by a “grass mesh” parented to the landscape mesh. Here dupliverts doesn’t work for static particle systems.
(Don’t ask me why)
The dupliverted objects will behave like for a non static particle system, they will move on animation and won’t show up in the fist frame if the particle system’s start frame is set to 1.

To make such a sytem pseudo static, add a straight horizontal time Ipo to the particle system and give it a Y-axis value (scale frames) which fits your needs.

But I could have complete misunderstood what your intention is. :-?

You don’t turn dupliverts on. Dupliverts are dupliverts (it makes duplicates of children on the verts of the parent) and particles are particles.

The buttons I gave you above are the only ones you need to activate the particle stream. (Except, of course, for Static which you already have, and Halo which is optional)
Then you’ll have to set ‘Z-force’ negative to get the curve.

In your 3D view (look thru the camera) you must be able to see white particle streams as blades of grass.


I’m following this tutorial on the Blender website:

Objects as particles
It is very easy to use a real object as particles. Start by creating a cube, or any other object you like, in your scene. It’s worth thinking about how powerfull your computer is as we are going to have as many objects, as “Tot:” indicates, in the scene. Scale the newly created object down so that it matches the general scene scale.

Now select the object, then SHIFT-RMB the emitter and make it the parent of the cube using CTRL-P . Select the emitter alone and check the option “DupliVerts” in the AnimationButtons (F7 ). The dupliverted cubes will appear immediately in the 3DWindow.

The particle “strings” are just not workable… they look like tube-worms… all soft and rounded. They look absolutely nothing like grass.

All I’m trying to do is the same as one would do to make leaves on a tree as a particle system.

To make such a sytem pseudo static, add a straight horizontal time Ipo to the particle system and give it a Y-axis value (scale frames) which fits your needs.

Tordat… thanks! Why don’t dupliverts work on static systems? It seem awefully counter-intuitive.

If you want, PM me your email addy and I’ll send you a .blend with particle grass (no dupliverts) and a tree with dupliverted leaves.


Thanks everyone for your help. I finally got it working. I’ll post a pic shortly in the WIP section.