Trouble with yafaray script.

I got some trouble when i start up the yafaray script in blender. Then i get an error message like this. I got python 2.6 and using the latest blender 2.49a.

Checking for installed Python… got it!
YafaRay 0.1.1
~yafrayInterface_t() delete scene…delete environment…done
YafaRay 0.1.1
~yafrayInterface_t() delete scene…delete environment…done
YafaRay 0.1.1
Traceback (most recent call last):
File “<string>”, line 1, in <module>
File “/home/kjell/.blender/scripts/blender/yafaray_ui.py”, line 2349, in <module>
main()
File “/home/kjell/.blender/scripts/blender/yafaray_ui.py”, line 2342, in main
TabMaterial = clTabMaterial()
File “/home/kjell/.blender/scripts/blender/yafaray_ui.py”, line 302, in init
self.yRender = yaf_export.yafrayRender()
File “/usr/share/yafaray/blender/yaf_export.py”, line 65, in init
self.yi.loadPlugins(dllPath)
File “/usr/share/yafaray/blender/yafrayinterface.py”, line 97, in loadPlugins
def loadPlugins(*args): return _yafrayinterface.yafrayInterface_t_loadPlugins(*args)
TypeError: in method ‘yafrayInterface_t_loadPlugins’, argument 2 of type ‘char const *’

Hi!

I get almost the same message when trying to access yafaray from Render menu:

Checking for installed Python… got it!
could not change language to ro nor ro.UTF-8
YafaRay 0.1.0 (315)
Traceback (most recent call last):
File “<string>”, line 1, in <module>
File “/home/admiral/.blender/scripts/blender/yafaray_ui.py”, line 2080, in <module>
TabMaterial = clTabMaterial()
File “/home/admiral/.blender/scripts/blender/yafaray_ui.py”, line 250, in init
self.yRender = yaf_export.yafrayRender()
File “/usr/share/yafaray/blender/yaf_export.py”, line 113, in init
self.yi.loadPlugins("")
File “/usr/share/yafaray/blender/yafrayinterface.py”, line 97, in loadPlugins
def loadPlugins(*args): return _yafrayinterface.yafrayInterface_t_loadPlugins(*args)
TypeError: in method ‘yafrayInterface_t_loadPlugins’, argument 2 of type ‘char const *’

What can we do???

God help us!
Regele IONESCU

Try this - http://www.yafaray.org/community/forum/viewtopic.php?f=13&t=2423

Regele IONESCU you are possibly using the wrong version of Yafaray. Blender 2.49 is compiled with Python 2.6, while Yafaray 315 is compiled with Python 2.5. You may find it helpful to use Yafaray 0.1.1 RC 3 for Python 2.6. Be sure to completely remove all traces of the previous Yafaray install and all the .py scripts related to it before installing the later version.

Yafaray 0.1.1 RC 3 for Python 2.6

This is the only way I got Yafaray to work. I had to upgrade my Blender and chose the 0.1.1 RC3 version of Yafaray.

Hi! I upgraded to yafaray 0.1.1. RC3 AND removed Python 2.5 and 3!!! Now works fine. Thank you guys!