Troubles Compiling Blender 2.43 in Fedora Core 6

Well, Blender was having troubles on my computer, so someone recommended that I compile it from source. I tried to compile it with SCons, and got this:

scons: Reading SConscript files ...
Command-line arguments
        No  command-line arguments given
Command-line targets
        No targets given, using default
Using config file: config/linux2-config.py
user-config.py not found, no user overrides
Linux platform detected:
  checking for FreeAlut... failed
Building in ../build/linux2/
Configuring library bf_soundsystem
Configuring library bf_string
Configuring library bf_ghost
Configuring library bf_guardedalloc
Configuring library bf_bmfont
Configuring library bf_moto
Configuring library blender_CTR
Configuring library bf_memutil
Configuring library bf_decimation
Configuring library blender_IK
Configuring library blender_bop
Configuring library blender_ONL
Configuring library bf_elbeem
Configuring library blender_BSP
Configuring library extern_ftgl
Configuring library bf_avi
Configuring library bf_blenkernel
Configuring library bf_blenlib
Configuring library bf_blenloader
Configuring library bf_blenpluginapi
Configuring library bf_imbuf
Configuring library bf_cineon
Configuring library bf_dna
Configuring library blender_python
Configuring library blender_radiosity
Configuring library bf_readblenfile
Configuring library blender_render
Configuring library src
Configuring library bf_yafray
Configuring library bf_ftfont
Configuring library bf_openexr
Configuring library bf_kernel
Configuring library blender_creator
Configuring program blender
scons: done reading SConscript files.
scons: Building targets ...
Compiling ==> 'SND_OpenALDevice.cpp'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:51:19: error: AL/al.h: No such file or directory
intern/SoundSystem/openal/SND_OpenALDevice.cpp:52:20: error: AL/alc.h: No such file or directory
intern/SoundSystem/openal/SND_OpenALDevice.cpp:53:21: error: AL/alut.h: No such file or directory
intern/SoundSystem/openal/SND_OpenALDevice.cpp:72: error: ‘ALvoid’ does not name a type
intern/SoundSystem/openal/SND_OpenALDevice.cpp:73: error: ‘ALvoid’ does not name a type
intern/SoundSystem/openal/SND_OpenALDevice.cpp:77: error: ‘ALubyte’ does not name a type
intern/SoundSystem/openal/SND_OpenALDevice.cpp:78: error: ‘ALsizei’ does not name a type
intern/SoundSystem/openal/SND_OpenALDevice.cpp:79: error: ‘ALubyte’ does not name a type
intern/SoundSystem/openal/SND_OpenALDevice.cpp:84: error: ‘ALushort’ does not name a type

...etc...

scons: *** [/home/.../Installers/blender/build/linux2/intern/SoundSystem/openal/SND_OpenALDevice.o] Error 1
scons: building terminated because of errors.

There were a lot more errors, all having to do with the apparently missing files “AL/al.h,” “AL/alc.h,” and “AL/alut.h.” Plain old “make” does the same thing. I have no idea what AL is supposed to be, but (correct me if I’m wrong) I think it’s part of the OpenAL package that the INSTALL file says I need. Trouble is, I’ve already got OpenAL installed, which would appear to contradict this. Any suggestions? Did I miss something terribly obvious?

EDIT: I forgot to mention, this happens with both 2.42 and 2.43. Older versions give me different errors.

youre probably missing some necessary packages on your computer. first Id just install blender from fedora extras because that one works fine, it is version 2.42a though.
once you get it installed you need to go get this package compat-libstdc+±33 -3.2.3-61.i386
once you have that installed download the precompiled 2.43 version
extract it as normal user. switch to root
rename the file blender to blender.bin that is in the extracted folder
then move the files blender.bin and blenderplayer to your usr/bin folder
overwriting the files that are there.
Then you should be running 2.43 as I am.

The whole point of compiling from source is because Blender doesn’t work fine on my computer, even though it is properly installed. Here’s a thread I posted a while back about that:
http://blenderartists.org/forum/showthread.php?t=87846
Basic summary: under certain (common) conditions while using Blender, X restarts, returning me to the login screen and ending any programs I have running.

first Id just install blender from fedora extras because that one works fine, it is version 2.42a though.
Already tried that; it crashes (see above thread).

once you get it installed you need to go get this package compat-libstdc+±33 -3.2.3-61.i386
Already got it.

once you have that installed download the precompiled 2.43 version
It almost works fine, except it still has the problem described in the thread above.

So, it would be nice if I could actually compile it from source to see if that fixes the problem.

EDIT: After fiddling with some settings, I got it to compile. After a while, though, it hits this point and stops:

...

Linking program ==> 'blender'
/usr/bin/ld: cannot find -lgettextlib
collect2: ld returned 1 exit status
scons: *** [/home/.../Installers/blender/build/linux2/bin/blender] Error 1
scons: building terminated because of errors.

Any ideas?

Do you have a file named ld in your usr/bin folder?
thats ld the gnu linker.
It seems to be having trouble getting a certain text value, I dont know why though.
have you installed all the common development libraries for compiling?

Marvin X (or stillme on the channel if I can remember :slight_smile: )

You’re missing OpenAL and OpenAL - devel packages.

I thought I told you to install this already ?

/usr/bin/ld: cannot find -lgettextlib

That line says the linker (ld) is looking for a library called libgettextlib.* where * is either .so or .a.

Bottom line: you need to install the gettext and gettext-devel packages or fix the settings for BF_GETTEXT* in your config file.

As for that openal stuff, as a rule of thumb, if you need a package foo to run blender, you need to install foo-devel to build it. Libs are in foo, headers (.h files) are in foo-devel.

Thank you for all your help, guys! I managed to get it to compile. Sadly, though, that didn’t fix the original problem, so I’m back to square one. :spin:

(Oh, and Wolf, I’m afraid you have me confused with someone else.)

What graphic card do you have? Ati?
What drivers are you using, Ati’s closed source or other?

It seems that this must be somehow related to your OpenGl not being good.

EDIT: Any change to try with other machine?

My graphics card is nVidia GeForce Ti 200. Before I upgraded to Fedora Core 6 it worked perfectly with Blender, and Blender is the only program that causes problems.

EDIT: Any change to try with other machine?

I’m not sure what you mean. I have another machine (also FC6) which has a different graphics card; I’ll try Blender there and see if it works.