Troublesome Mice

So I know that blender works with the common (I think) three button mouse for the computer. But unfortunately my mouse is a four button mouse with the ball on top. The problem is very simple but I was wondering if there was a solution that can help me.
Normally If you use a three button mouse you can use the middle button to easily navigate the 3D window but with my four button mouse I can’t do that. The two extra buttons do nothing. Is there maybe a place in the preferences that I can change that or assign them to something?

Didn’t your mouse come with driver software? I think you can configure your mouse there; not in Blender.

Nope. I run Fedora 15 and I jut plugged in the mouse and it works fine. Like in Firefox the two extra buttons are shortcuts to go back and foward between pages and the same thing apples for my file browser. Odd thing is I Currently run blender 2.59 but when I ran it on Fedora 14 using blender 2.49 the buttons worked fine.

User Preferences =>Input “Emulate 3 button mouse”? Just guessing; I don’t know what that means…I got my 3 button (scroll wheel) mouse for five bucks.

There is a little app called imwheel, which enables you to use more than three mouse buttons and remap them under X.
I’m on ubuntu, but it should be in the fedora repositories, too.
Also this guide should apply similarly

“Emulate 3 button mouse” means you will then use Ctrl + LMB in place of wheel.