trunk compiled blender with osl enabled - missing script node

hi

i just built blender trunk 2.64.9 r52413 with osl enabled
on ubuntu 12.04( 32 bit )

cmake options after succesfully compiling all libs with the new install_deps.sh script :

cmake …/blender -DCYCLES_OSL=/opt/lib/osl -DWITH_CYCLES_OSL=ON -DLLVM_VERSION=3.0 -DWITH_INTERNATIONAL=OFF -DOPENIMAGEIO_ROOT_DIR=/opt/lib/oiio -DOPENCOLORIO_ROOT_DIR=/opt/lib/ocio -DBOOST_ROOT=/opt/lib/boost -DBoost_NO_SYSTEM_PATHS=ON -DWITH_CODEC_FFMPEG=ON -DFFMPEG=/opt/lib/ffmpeg -DFFMPEG_LIBRARIES=‘avformat;avcodec;avutil;avdevice;swscale;rt;theoraenc;theora;theoradec;vorbis;vorbisenc;vorbisfile;xvidcore;vpx;mp3lame;x264;openjpeg;schroedinger-1.0’

all compiles well
and when i execute blender
the “Shading Syst” option is there and ‘Open Shading Language’ selected
but in the node editor under “Add” there is no ‘script’ node


the node isn’t directly under “Add” where i think it should be
nor under any of the subdirectories of “Add”


the search function under “Add” doesn’t return the ‘script’ node either

anybody else having this issue ?

it is a 32 bit thing
or i’m going crazy :slight_smile:

regards
sc3*2

You are in the Compositing Nodes. You need to be in the Shader Nodes.

thanks a lot DingTo for you patience

, glad i’m not crazy
just stpd :slight_smile: