Trying to customize the GUI

Hello guys,

I started modeling using Maya’s Student Licence, which I’m not allowed to use anymore.
Decided to give Blender a try, but I’m currently fighting the GUI, which I’d like to change a bit. I don’t wanna use the Maya preset, I just want to change few things, so I can actually follow the commands and hotkeys from tutorials.

Here’s few things that I’d like to change but not sure how:
1.) Box selection all the time - instead of having to press “B” and then drag, is there a way to set it so I can just drag anytime as in Maya?

2.) Disable auto-translate - what I mean is that when you drag over an object, it goes to auto-translate mode, where you can move it anywhere in the 3D space. I find myself accidentally moving objects a lot, probably because of 1.) when I’m trying to actually box-select stuff.

3.) Deselect by clicking on empty space - when I’m trying to box-select using “B”, it adds to my selection automatically. So first I need deselect all ("a) and then do it. That’s two extra keys for something I used to do with click and then mouse drag. Any way to change it to Maya style?

4.) Edge Loop Tool - Smooth - could not find more detailed info in the manual. I’m wondering what those values actually represent. I just want to set it to averaged edge flow, is it value 1.0? And is there a way to set tool’s default values like this smoothness parameters in the Edge Loop Tool?

Thank you very much for your help and time!

Great, thank you!

EDIT: Actually, still not happy, sorry :slight_smile:
I tried your suggested 1.), but…

  • dragging adds to current selection, instead of only selecting whatever I marquee. So I still cant just marquee a vetex, transform it, and then marquee next one
  • and most importantly, neither clicking nor dragging outside of my object/vertex in object/edit mode works like deselecting, so I still need to press “A”.
  • 2.) was solved by this though, without adjusting the tweak treshold whatsoever

EDIT2: Actually, with this setting I now can’t translate/rotate/scale using object transform handles. It just deselects in and tries to border select.

Oh boy, it’s so confusing.

Are you sure you unchecked the ‘extend’ checkbox?

Ooops. It was greyed out, didn’t know I could actually uncheck it…

Works better now, getting there!
I can now marquee anything and marquee outside to deselect.
But since it doesn’t add to selection now, I tried using shift-marquee, but that doesnt work.
Shift-clicking still works though.

You have to make another similar binding except with shift and the extend both checked.

Right, so I made a new (second) hotkey for “Border select” and made it with “Shift” and “Extend” checked.

Now when I shift-marquee, it only functions for deselecting any already selected verticies, but it won’t select any. :confused:

EDIT: Tried to disable Shift-mouse in the 3D Manipulator hotkey. And also all other tweak events in the 3D View (Lasso and Translate) - No change.

Oh well, nevermind box selection. Already got used to the A/B combo… :slight_smile: