Trying to import and OBJ, getting an error...

So I’m trying to import a .obj file into Blender and I’m getting an error message. I’ve imported a ton of .obj files before and never seen this. Does anyone know what this is all about?


Are you using bmesh, because I ran into the same issue, just download another build.

How can I tell if I am? And what build would you suggest?

I have seen similar errors before. Some OBJ files just don’t work with Blender. You have to use another program to convert them into another format. Perhaps wings, poser, truespace etc…

Whenever you post something like this, make sure to be specific about exactly which version of blender you use and preferably what OS. (Also: Support forums are better a better fit than for this)
You are using bmesh if you are running any of the more recent builds after the 2.62 release. Those builds are currently not in a stable state to work with.

Sorry about that… I’m on the Windows 2.62 build released on a couple weeks ago.

And Atom, I’ll try downloading one of those.

Thanks for the info.

If you’re on a release build, it’s a bug. Please report it and make sure to attach the OBJ file if that is possible. Also if you’re using a 64-bit build, consider trying a 32-bit build. (bitness is also important information, make sure to supply it!)

The script needs to be updated. You can use an older version of Blender to import the obj, save as a blend, then open it in the new version.

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

Well, I think it was an issue with that OBJ… I tried an older version of Blender and was still getting the same error. The file came with a Cinema 4D file as well, so I ended up downloading the trial version of Cinema 4D and opened it up with that, exported it as an OBJ and imported it just fine into Blender.

Thanks for all the suggestions everyone.

Please consider writing a bug report, still. OBJ is a very simple format and any errors in the script shall be readily fixed.