Trying to learn Blender but the lights in render mode is not working like in the tutorial!

For some reason the lights are not working in render mode! I would like to know how to fix this! Please!
Video of Tutuorial that im trying to learn from: https://www.youtube.com/watch?v=bpvh-9H8S1g

Does cycles work?

What do you mean by cycles?

On the right, it says Render Engine: Eevee. If you change it to cycles, does the light work?


That cycles render engine but it does a weird fussy thing when i zoom, pan, tilt, rotate and the objects are fuzzy in texture.

Cycles is a render engine that is designed for acuracy and eevee is more like a real time renderer like in games. Eevee has limitations with lighting and cycles is more resource intense and is slower. Read the blender manual its actually helpful lol.or maybe a tutorial that goes over the basics of blender and its features


See i would agree with you if i hadn’t looked at the tutorial again. The guy is using the exact same render engine that i was initially using which is Eevee. Why is his lighting working but mine isn’t!

I’m going to take a wild stab in the dark and guess you have an AMD graphics card with drivers updated fairly recently? If so, roll them back to whatever one was available in November or thereabouts.

Yes there would be a difference in look and wuality depending on the hardware and drivers

I upgraded my pc so that i could run blender.
here are the upgraded specs:
MB: X570 Aorus Elite
AMD Ryzen 5 2600
Gigabyte Radeon RX5600
Sound Blaster Audigy FX sound card
Cosair Vengeance LPX 32gb of memory
Elgato HD60pro.

I’m not sure how to get the previous drivers if possible

I don’t have an AMD GPU, but you could try looking in your Device Manager

If you do a search here for “AMD drivers” you will find post after post for about the past 8 weeks or so with people complaining about the same or similar issue. AMD have badly messed up. I wouldn’t have an AMD graphics card in my PC if you paid me.

i have that option but its greyed out. I freshly upgraded my pc so thats probably why.

Temporary workaround you could try that some users have found to work.
Render Properties-> Performance-> Use High Quality Normals.

This might depend on the exact card and driver though.

I did a quick search on Google for AMD Radeon Drivers, and on the first result, I selected the Radeon RX 5600 series and hit submit. On the next page (which automatically loads the most recent driver) I clicked a link that said “previous drivers” and brought me to this page: https://www.amd.com/en/support/previous-drivers/graphics/amd-radeon-5600-series/amd-radeon-rx-5600-series/amd-radeon-rx-5600-xt

I don’t know what OS you have or how far you need to go back (I feel like I’ve heard AMD users complaining for a month or two), but this should get you what you need.